Quick add don't download files


  • | 108 points

    I just installed version 4.0.3.181210 version on windows 10. When I try do add ruby for example, I have a modal with Downloading. The progress don't fill


  • administrators
    | 113950 points


  • | 519 points

    First of all thanks for the amazing program but I have the same problem but with wordpress.

    The download screen does nothing when I want to install wordpress using Quick App. I tested it on different networks and just to be sure I also tested it by adding the proxy but with no success.

    I then checked the tmp\downloads folder and the wordpress archive is downloaded so I think the program doesn't see that the program is fully downloaded?

    What seems to work is when I change the download link in the sites.conf file to version 4.9.8.

    The only difference I see is the size of the archive:
    -> wordpress 5: 10.02MB
    -> wordpress 4.9.8: 8.34MB

    Can the size be the reason the download / extract doesn't work if the size is larger than 10MB? Because in one of the previous version of laragon I had the same problem and changing the download link back than from the tar.gz to zip file made it work (the zip file was under 10MB and the tar not).

    Usefull info:
    Windows 10 1809 and laragon 4.0.3


  • administrators
    | 113950 points

    @bazad : Many thanks for your information. There are reports about the same issue when filesize > 10MB:
    https://forum.laragon.org/topic/558/quick-create-freezes-on-after-download-on-laragon-wamp-3-1/11

    However, it works with the others (including me). I'll consider the issue and find a way to fix it.


  • | 108 points

    @leokhoa

    Thanx for your help. I tried to change the proxy but it didn't resolve my problem.


  • | 646 points

    @leokhoa Hello,

    I have the same problem with files > 10MB : files have been downloaded in /tmp/downloads/ but the progress bar stays blank and project folder is not created. No problem with files < 10MB.

    Strange that some people get it working and others don't.

    Hope you will find a solution :slight_smile:


  • administrators
    | 113950 points

    @Laurent-PQ , @bazad : The link which returns a Proxy may give you wrong, out-of-date ones. Can you test with this Proxy:

    Proxy=138.68.138.121:3128
    

    If it succeeds, I will think about making a list of updated Proxies for reliability.


  • administrators
    | 113950 points

    @kemar2012 :
    As some users having the issue, I want to fix it but I can not reproduce it. Can you open Terminal and run that command, then send me the image of the result?

     curl -L  "https://wordpress.org/latest.zip" -o C:\test.zip
    

    I expect to see an error.

    Note: You can delete C:\test.zip afterward.

    @kemar2012 said in Quick add don't download files:

    @leokhoa Hello,

    I have the same problem with files > 10MB : files have been downloaded in /tmp/downloads/ but the progress bar stays blank and project folder is not created. No problem with files < 10MB.

    Strange that some people get it working and others don't.

    Hope you will find a solution :slight_smile:


  • | 646 points

    @leokhoa :
    There is an error caused by the path C:\test.zip (Failed to create the file. Permission denied.).
    But if I set the path to C:\laragon\test.zip for example, no problem. File is downloaded.

    Don't know if it help ?

    EDIT : The path C:\test.zip works fine when running cmd with administrator rights.


  • | 519 points

    I tested it with the proxy you provided but still no success.

    I did some more testing:

    1. Test the curl command in the post above and it works when I save the output to my laragon installation folder (D:\Laragon). Like @kemar2012 said you can only save the output to C:\ when running cmd in admin mode
    2. Also tested running laragon in admin mode -> Still the same problem
    3. Complete new virtual installation of windows 10 1809 with only laragon installed -> Still the same problem
    4. I also test with another download location, not that I thought it would make a difference but just to be sure and to rule everything out -> still the same problem

    I think the problem lies with it not detecting a successful download or something with the extraction process. Why? I don't know and to make it stranger not everyone has this problem.

    EDIT: I just tested something else and that was to just download the wordpress files trough the browser and the download was quick but it took some time for the security scan to finish. Is there some kind of timer in laragon and does the security scan just takes to long?

    @leokhoa said in Quick add don't download files:

    @Laurent-PQ , @bazad : The link which returns a Proxy may give you wrong, out-of-date ones. Can you test with this Proxy:

    Proxy=138.68.138.121:3128
    

    If it succeeds, I will think about making a list of updated Proxies for reliability.


  • | 108 points

    @leokhoa

    Hi

    No it don't download :(


  • | 2489 points

    I'm having this issue too with Node :-(


  • | 750 points

    @ivanhalen said in Quick add don't download files:

    aving this

    I have the same problem. Please help


  • | 120 points

    I think the problem lies with it not detecting a successful download or something with the extraction process. Why? I don't know and to make it stranger not everyone has this problem.

    I agree - the file IS downloaded.

    Same issue (Win 10 1809). The file is downloaded to the \laragon\tmp\downloads directory (e.g. 20181227105617.wordpress.latest.tar.gz), the progress bars just stay blank and nothing happens.

    In my case, the Laragon directory is on a secondary drive (not C:)


  • | 750 points

    yes, and strangely, it only happen to files larger than 10mb, i also tested with older wordpress (v4.9), it does work.


  • administrators
    | 113950 points

    @KaiToU-KiD, @catch , @ivanhalen , @Laurent-PQ, @bazad , @kemar2012 :
    I've released Laragon 4.0.5. You can apply the patch here:
    https://github.com/leokhoa/laragon/blob/master/laragon.exe

    I hope it works. If not:

    1. Please turn on Debug and check what in laragon.log (Menu > Laragon > laragon.log). To turn on, add this to laragon.ini (Menu > Laragon > laragon.ini) - under [preferences] :
    [preferences]
    Debug=-1
    

    Note: If auto-download don't work for you, you can download wordpress.tar.gz and put it to "C:\laragon\usr\wordpress.tar.gz", then add to Configuration (Menu > Quick app > Configuration)

    Wordpress Local=C:\laragon\usr\wordpress.tar.gz
    

  • | 750 points

    @leokhoa

    i've apply the patch but when i run it it says in the title: laragon lite 3.5.2
    and there's button 1

    0_1545979026916_upload-dbac6898-cd12-4fab-84b5-377012a7cb46 image url)

    i've try new quick app - wordpress but the download doesn't work, no files downloaded in laragon\tmp\downloads

    i've turned on debug, but i think there's none added to the log

    i've try downloaded manually, and set the configuration to local folder, it copied the files (20181228133325.wplatest.local.wordpress-5.0.2.tar.gz), but there's no progress in the quick app window, and none extracted

    that's my report, thanks in advance


  • | 750 points

    my laragon.log:

    2018-11-29 16:48:56: SSL: Signature ok
    subject=C = SG, ST = Singapore, L = Singapore, O = Laragon, OU = IT, CN = laragon
    Getting Private key

    2018-11-29 16:51:27: SSL: Signature ok
    subject=C = SG, ST = Singapore, L = Singapore, O = Laragon, OU = IT, CN = laragon
    Getting Private key

    2018-12-20 17:13:52: Laragon: Unable to assign CTRL+ALT+T as hotkey to open Terminal.
    2018-12-20 19:17:16: SSL: Signature ok
    subject=C = SG, ST = Singapore, L = Singapore, O = Laragon, OU = IT, CN = laragon
    Getting Private key

    2018-12-20 20:23:11: Laragon: Unable to assign CTRL+ALT+T as hotkey to open Terminal.
    2018-12-20 20:36:08: Laragon: Unable to assign CTRL+ALT+T as hotkey to open Terminal.
    2018-12-26 10:58:31: SSL: Signature ok
    subject=C = SG, ST = Singapore, L = Singapore, O = Laragon, OU = IT, CN = laragon
    Getting Private key

    2018-12-28 13:26:27: Laragon: Unable to assign CTRL+ALT+T as hotkey to open Terminal.


  • administrators
    | 113950 points

    @KaiToU-KiD : Oh, terrible. I pushed a wrong file. So sorry.


  • | 8449 points

    Trying to add Magento with no success, wordpress downloaded, but the custom magento download url, (from github) doesn't work , it keeps freezing


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.