Quick SSL working in every browser except for Firefox - any help is appreciated since Firefox is my main browser


  • | 107 points

    I've tried everything. Re-installing, changing ports, domain names, created new projects .... no luck, I only get secure connections inside Chrome, Edge and IE. Using latest version of Laragon :)


  • | 386 points

    @dueify That is because Firefox uses its own certificate store instead of using the operating system's certificate store.
    If you want to instruct Firefox to instead trust what they set up in the Windows certificate store, you can try this:

    (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.
    (2) In the search box above the list, type or paste enterp and pause while the list is filtered
    (3) Double-click the security.enterprise_roots.enabled preference to switch the value from false to true

    Now Firefox should accept your https url, but since the SSL certificates are self-signed by laragon, there will be an exception and you need to accept that once for every local URL. I proposed a change for this on github and hope it will be changed accordingly.

    I also can recommend a small (open source) utility you can get from here: https://github.com/zumoshi/BrowserSelect/releases/download/1.4.0/BrowserSelect.exe
    It must be installed as your default browser and whenever you follow a link (also from Laragon) you can tell wicj browser should handle it. My default browser is also Firefox and i like to use Chrome as my main development browser.


  • | 107 points


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.