Quick app 'No file:' error - [Laragon 4.0.10]


  • | 674 points

    The quick app feature is producing an error with the latest version of laragon@4.0.10, Windows 10 pro 1809

    I can not locate where the cached file is downloaded, as all directories in the laragon "tmp" folder ( "cached", "downloads", "extract" etc.) remain empty throughout the quick app process. The quick app process does however auto create the database, but does not create any project folder in the "www" directory.

    I have tried disabling the firewall, changing folder permissions, read/write access, running Laragon as administrator, all with no effect. I was wondering what the cause of this error could be?

    @leokhoa Hope you are very well, any ideas on what could be causing this ?

    Many thanks

    Screenshot:

    Laragon No file imgur

    Log file (Excerpt):

    2019-02-18 02:22:17: SSL: Signature ok
    subject=C = SG, ST = Singapore, L = Singapore, O = Laragon, OU = IT, CN = laragon
    Getting Private key

    2019-02-19 16:30:37: Cached File: E:\_Bin\laragon\tmp\cached\wordpress.latest.tar.gz
    2019-02-19 16:31:34:
    2019-02-19 16:31:34: Cached File: E:\_Bin\laragon\tmp\cached\drupal.drupal-8.5.5.tar.gz
    2019-02-19 18:06:52:
    2019-02-19 18:06:52: Cached File: E:\_Bin\laragon\tmp\cached\wordpress.latest.tar.gz


  • administrators
    | 105080 points

    @akhirunNahr : What is your OS language?


  • | 674 points

    @leokhoa

    edit: OS language is US English. Sorry, I just realized you were referring to regional language and not programming language. Too much time in front of computers made me forget there are spoken languages as well besides programming languages. 🤦‍♂️ 😄

    I'm on Windows 10 pro Version 1809 (OS Build 17763.316) February 12, 2019 Update and I am using the Laragon 4.0.10 WAMP package installer. "E:\_Bin" is the directory I have created where I install all my development tools. So Laragon is installed in "E:\_Bin\Laragon"

    I tested Laragon 3.5 and it is working perfectly and the quick app is working as expected, so the issue seems to be directly related to the v4.x releases.

    I will roll back each successive v4.x release of Laragon, and post back with the results asap, it might help narrow down which version it is exactly that is causing the issue. (Maybe a re-install of the v4 release will fix the issue)

    Many thanks for your help


  • administrators
    | 105080 points

    @akhirunNahr : Many thanks for your information.
    Can you also test with the DownloadWaitTime directive?
    https://forum.laragon.org/topic/1320/sort-out-the-download-issue-with-curl-in-quick-app-and-quick-add/2


  • | 674 points

    @leokhoa

    Great! The DownloadWaitTime directive does indeed work.

    Currently I have set it to DownloadWaitTime = 5000 and it is working.

    It does not however work with values of 4000 and below. It only works with values of 5000 and above.

    Although while writing this, I cleared the cache and even with a value of 5000 it did give the error once more. Kind of a 'hit and miss' situation going on. There is indeed some issue with the curl executable, and the behavior is slightly unpredictable, as the Quick-app process has still on a few occasions proven to produce the error.

    Please let me know if I could provide any further information, I would be more than happy to assist in any way at all.

    As ever, thanking you very much for your time and help.


  • administrators
    | 105080 points

    @akhirunNahr : Many thanks for your information.
    There must be something wrong when using curl to get and parse output.
    I'll consider another better method.


  • | 674 points

    @leokhoa

    That's great news, really looking forward to future updates! Thank you very much for all your help and the exceptionally amazing work with Laragon.

    The best of regards !


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.