Apache can't start


  • | 164 points

    alt text
    The apache httpd-2.4.38-win64-VC15 version cannot be started.
    The runtime libraries are all installed.
    Only version 2.4.38 cannot be started. 2.4.35 is normal.
    win7 X64


  • | 164 points

    How to solve this problem?


  • | 407 points

    Try reinstall visual C++ redistributable, you can download here.


  • | 164 points

    hi @indra
    I have tried to reinstall visual C++ redistributable and all versions of 2008-2019 are installed. Visual studio 2017 is also installed. But still can't start.


  • | 407 points

    @ziselive sorry if reinstalling visual C++ redistributable still can't solve your problem, but I recommend to try installing apache without laragon and see if you can run it or not. If you can run apache without laragon, then you can ask to laragon creator :)


  • | 180 points

    Just download and install the latest full version of laragon. This is my first time using laragon and I don't encounter any issues. I just hate some bloatware like notepad++.


  • administrators
    | 112691 points

    @jreloz : Notepad++ is awesome. It is fast & lightweight. Why do you call it a bloatware :)
    When you read files from Mac & Linux, Notepad will display them wrongly.


  • | 180 points

    @leokhoa Im sorry, I didn't under estimate the usefulness of notepad++ but I prefer the built-in notepad when editing windows system files with admin privilege and maybe I use the term bloatware incorrectly. .


  • | 164 points

    @indra @leokhoa Hi guys, I solved this problem. The latest version of apache can't be started.
    because Laragon copied the lower version of the php ssl library to the apache /bin folder. PHP upgrade to the latest version can solve this problem.


  • administrators
    | 112691 points

    @ziselive : Nice catch! I will fix the behaviour soon.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.