PHP version and Apache version are not compatible.


  • | 265 points

    Hi all, I'm downloaded portable version of laragon. But I keep on getting these error "PHP version and Apache version are not compatible" after I'm update the version of my PHP and Apache.
    Error img

    My PHP version is 7.3 (7.3.5) VC15 x86 Thread Safe. Website
    Apache is Apache 2.4.39 Win32 Website

    What did I do wrong here? Thanks.
    Am

    Am


  • administrators
    | 113323 points

    @mossymoo : I guess you extract to a wrong dir.
    To fix it, you can delete the dir then adding Apache by using Menu > Tool > Quick add


  • | 265 points

    Hi, it seem that by using Menu > Tool > Quick add will install apache 64 bit. Is there option for me to choose to install 32 bit by using the same method?


  • administrators
    | 113323 points

    @mossymoo: Sure, just update the "Quick add > Configuration" and change Apache link to a 32-bit version.


  • | 265 points

    @leokhoa It works! Thank you so much!


  • | 26 points

    I am also getting the same error. As per your suggestion mossymoo, my problem is not resolved. What to do?


  • | 265 points

    @westernira as @leokhoa said, empty your apache folder. Go and add apache by using Menu > Tool > Quick add.

    If you're using apache 32 bit, make sure your PHP also 32 bit. Same goes with 64 bit.

    By using Menu > Tool > Quick add in default setting will install a 64 bit for you. If you want to change it to 32 bit just go to Menu > Tool > Quick add > Configuration, replace apache 64 bit link to 32 bit link.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.