Homestead To Laragon Server not working. *Help*


  • | 300 points

    Hello, first of all I am impressed on how easy it was to get a laravel project started I have tried many options and this was sooooo easy so I loved it... So thanks for this project.

    Now I have a little issue, I have a project that uses react on the front, and lighthouse on the back, i was using this project on my homestead and it was working fine, but I'm trying to switch to laragon and the problem is that the front-end the client-side react is render correctly but any calls to the API do not work. I have been trying to solve this problem for more than a week and I've had no luck I really would appreciate support.

    [03-Jun-2019 19:45:37 UTC] PHP Warning:  require(C:\laragon\www\master3\public/../vendor/autoload.php): failed to open stream: No such file or directory in C:\laragon\www\master3\public\index.php on line 24
    [03-Jun-2019 19:45:37 UTC] PHP Fatal error:  require(): Failed opening required 'C:\laragon\www\master3\public/../vendor/autoload.php' (include_path='.;C:/laragon/etc/php/pear') in C:\laragon\www\master3\public\index.php on line 24
    [03-Jun-2019 19:45:38 UTC] PHP Warning:  require(C:\laragon\www\master3\public/../vendor/autoload.php): failed to open stream: No such file or directory in C:\laragon\www\master3\public\index.php on line 24
    [03-Jun-2019 19:45:38 UTC] PHP Fatal error:  require(): Failed opening required 'C:\laragon\www\master3\public/../vendor/autoload.php' (include_path='.;C:/laragon/etc/php/pear') in C:\laragon\www\master3\public\index.php on line 24
    [03-Jun-2019 19:45:54 UTC] PHP Warning:  require(C:\laragon\www\master3\public/../vendor/autoload.php): failed to open stream: No such file or directory in C:\laragon\www\master3\public\index.php on line 24
    [03-Jun-2019 19:45:54 UTC] PHP Fatal error:  require(): Failed opening required 'C:\laragon\www\master3\public/../vendor/autoload.php' (include_path='.;C:/laragon/etc/php/pear') in C:\laragon\www\master3\public\index.php on line 24
    [03-Jun-2019 19:45:54 UTC] PHP Warning:  require(C:\laragon\www\master3\public/../vendor/autoload.php): failed to open stream: No such file or directory in C:\laragon\www\master3\public\index.php on line 24
    [03-Jun-2019 19:45:54 UTC] PHP Fatal error:  require(): Failed opening required 'C:\laragon\www\master3\public/../vendor/autoload.php' (include_path='.;C:/laragon/etc/php/pear') in C:\laragon\www\master3\public\index.php on line 24
    [03-Jun-2019 19:45:55 UTC] PHP Warning:  require(C:\laragon\www\master3\public/../vendor/autoload.php): failed to open stream: No such file or directory in C:\laragon\www\master3\public\index.php on line 24
    [03-Jun-2019 19:45:55 UTC] PHP Fatal error:  require(): Failed opening required 'C:\laragon\www\master3\public/../vendor/autoload.php' (include_path='.;C:/laragon/etc/php/pear') in C:\laragon\www\master3\public\index.php on line 24
    

  • | 300 points

    @tomsmithh324236 Those are the only errors I see, I am new to php and on this project I have mainly worked on the front-end...


  • administrators
    | 115330 points

    @tomsmithh324236 : The images are truncated so it hard to see. Can you copy and paste full log here (Remember to quote them in '```)


  • | 300 points

    @leokhoa I'm sorry, I just updated it with it. BTW I have run composer install, npm install, and installed the db and connects properly and the react front end loads, but when trying to hit an endpoint from the API it says that it is offline.


  • administrators
    | 115330 points

    @tomsmithh324236 : From the errors, I think you should try to run composer install properly.
    Ref:
    https://forum.laragon.org/topic/175/tutorial-how-to-work-with-laravel-projects-on-github


  • | 300 points

    @leokhoa It may be that that is not the problem and there's another issue as to why the endpoint API is not working, im really clueless :/


  • administrators
    | 115330 points

    @tomsmithh324236 : Don't worry when there is issue, just remember to check your logs and figure out.

    Some tips to debug:

    1. curl to your endpoint:
    curl -iL your-end-point
    
    1. Check laravel's logs, apache's log, php's log

  • administrators
    | 115330 points

    @tomsmithh324236 : It works with new projects so I believe the root cause is in Lighthouse configuration.
    Please try:

    php artisan lighthouse:clear-cache
    

    Ref: https://lighthouse-php.com/master/performance/schema-caching.html


  • | 300 points

    @leokhoa Tried it and no luck :/ Still trying to figure out what the problem is.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.