(Site) Refused to connect


  • | 134 points

    Hello, was in the process of changing my WordPress theme. So, installed Laragon and in the process of setting Laragon. I used .COM as the site name and that is how I lost my connection to my site on my PC. I have tried all the means I know to access my site on PC without success. I still get this error, THE SITE CAN'T BE RECHEAD the site refused to connect. Any help please?

    My site is https://healthydoz.com


  • | 3487 points

    Did you configure your hosts file (open C:\WINDOWS\system32\drivers\etc\hosts or click on the "h" in the top-right-hand corner on the Laragon control panel) to assign a local IP to healthydoz.com? I would start there and delete whatever local references you have to that address so the actual site address will resolve correctly.

    Aside from that, I would suggest using the .test TLD that Laragon gives you out of the box to set up your WordPress site locally.

    If you open up the preferences menu (click on the orange socket in the top-right-hand corner), you should see an auto virtual hosts option at the bottom (whose checkbox should be checked).

    Under that, you should see a hostname option with {name}.test in the text field.

    This means that when you create a folder in the C:/laragon/www folder, Laragon will automagically do the plumbing and routing behind the scenes to serve whatever HTML or PHP files you create at your-domain-name.test. You can change it if you'd like, but for the sake of simplicity and being productive, I would just stick with .test.


  • | 134 points

    @maxxheth woh! It works like magic. Imagine spending three days trying to solve this issue! Thank you very much, @maxxheth


  • | 3487 points

    My pleasure, @Taraga-T! Glad I could help! =)


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.