"Quick share" don't work with me


  • | 1094 points

    Hello, I am using laragon v 4.0.16 and I wanted to try "Quick share" feature , so when I choose the wordpress site I want to share from "right click menu -> www -> share -> share-project name" as in the attached images, I found the terminal opened and NGork link copied automatic but if I try to open this link from another device mobile or desktop, it gave me an error "Server Ip didn't found "
    0_1569775894188_screen1.jpg
    0_1569776014301_screen2.jpg


  • | 1094 points

    Is there any answer @leokhoa


  • administrators
    | 115691 points

    @waul
    Can you show me the Ngrok console?


  • | 1094 points

    Here it is
    0_1569937928687_Untitled.jpg

    and I tried to change the region to every possible option and the result is the same


  • administrators
    | 115691 points

    @waul : The console says 301. I think there is a redirection on your code.


  • | 1094 points

    this is the url given to me when share @leokhoa
    http://2e78d9b5.au.ngrok.io

    and this screenshot from my mobile while tring to access it
    0_1569941455220_71386965_443078296557536_3875986450226872320_n.png

    and this screenshot from my desktop with the same url open with out problems
    0_1569941510874_mob55.test.png

    Is there any other thing I have to install sothat "quick share " works fine ?


  • | 1094 points

    @leokhoa any help ?


  • | 1094 points

    I found solution
    /** Fix for NGROK 301 Moved permanently **/
    define('WP_SITEURL', 'http://' . $_SERVER['HTTP_HOST']);
    define('WP_HOME', 'http://' . $_SERVER['HTTP_HOST']);

    add these lines to wp-config file


  • | 12 points

    Landed here after finishing my integers calculation with the help of here guide.Thanks for this information. It useful


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.