Opcache not working


  • | 201 points

    Laragon is a useful tool, but not useful enough, since it crashes if the PHP Opcode Cache is enabled (and configured). Even phpMyAdmin quits. I didn't find any workaround. Her are some opcode related topics, but no answer by the developer given. This way you can't use Laragon for serious development. It seems to be only a playground for beginners. That's a pity.


  • | 201 points

    Sorry for my rant. You need to change your PHP version to the non thread safe one, for example: php-7.2.25-nts-Win32-VC15-x64. Non NTS-versions simply don't work work with opcache enabled on Windows. So this seems to be a Windows related issue.

    Download:
    https://windows.php.net/downloads/releases/ (look for "...nts..." in the file name. VC number must match with your Apache Version). And don't forget to configure your php.ini.

    Good luck!


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.