[BUG+Report] Random 502 Bad Gateway + fastcgi://127.0.0.1:9001 + ntoskrnl.exe


  • | 1372 points

    I have found a problem, that I don't know how to solve. Maybe it should be examined and fixed in an update?

    Within the last few weeks I startet getting a lot of random "502 Bad Gateway".

    As the admin suggest, look in the laragon/bin/nginx/nginx-1.16.0/logs/error.log

    What I can see is that the fastcgi is running on Port 9001.

    After a fresh reboot, and without starting laragon in server mode. I did run a check on port 9001:

    1. Start powershell (maybe in admin mode)
    2. Get-Process -Id (Get-NetTCPConnection -LocalPort 9001).OwningProcess

    In my case it prints like this:

    #######################################
    Handles NPM(K) PM(K) WS(K) CPU(s) Id SI ProcessName


    5794 0 204 3568 25.34 4 0 System
    ######################################

    I look up the PID (Process Id in task mannager)

    There is this exe file called:
    C:\Windows\System32\ntoskrnl.exe

    This exe file is using port 9001, and will conflict with Laragon i guess?

    It is some kind of system file I think.

    @administrators @leokhoa

    Here are people with similar problem (note the date of this github issue is recent):
    https://github.com/cretueusebiu/valet-windows/issues/131
    https://github.com/eclipse/mosquitto/issues/1580

    I maybe think it is something that has come in a windows update.

    How have I desperately split testet the problem:

    • I used chrome, firefox
    • I flushed my dns
    • I Created a new Laragon-wordpress-install
      problem is still there.

    I don't know how to move the fastcgi port and I don't know what to do with ntoskrnl.exe

    I think a lot of users is affected by this :-)

    In this thread he talks about some Intel driver, maybe? :
    https://github.com/cretueusebiu/valet-windows/issues/131


  • | 1372 points


  • | 1372 points

    Solved.

    This is a intel graphics card software related issue on windows 10.

    How to fix:

    In windows, go to:

    Start menu
    Type: Services:
    Find the service called: "Intel(R) Graphics Command Center Service"
    Right click > Properties > Startup type = Disabled
    This fixed the problem for me.. :-)


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.