Page load so slow


  • | 380 points

    I run a wordpress site. when i visit the pages is so slow.
    In the nginx errors logs.

    [notice] 5164#3596: signal process started
    [notice] 5720#7144: signal process started
    [notice] 5248#6612: signal process started
    [notice] 5312#1340: signal process started
    [error] 6268#5220: *68 WSARecv() failed (10054: FormatMessage() error:(15100)) while reading response header from upstream, client: 127.0.0.1, server: wp_watawebu.app, request: "POST /wp-admin/admin-ajax.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9001", host: "wp_watawebu.app:8080", referrer: "http://wp_watawebu.app:8080/wp-admin/post.php?post=9&action=edit"
    [error] 6268#5220: *21 WSARecv() failed (10054: FormatMessage() error:(15105)) while reading response header from upstream, client: 127.0.0.1, server: wp_watawebu.app, request: "GET /?ver=19042017104908 HTTP/1.1", upstream: "fastcgi://127.0.0.1:9001", host: "wp_watawebu.app:8080", referrer: "http://wp_watawebu.app:8080/wp-admin/post.php?post=9&action=edit"
    [notice] 5944#2428: signal process started
    [notice] 6156#4188: signal process started
    [notice] 6288#5068: signal process started
    [notice] 3452#6756: signal process started
    [notice] 1460#5312: signal process started


  • administrators
    | 46775 points

    @Luis-Wataweb : How many PHP processes are you setting now?


  • | 380 points

    @leokhoa Hi, I do not know how many PHP processes are running on my machine :(


  • administrators
    | 46775 points

    @Luis-Wataweb : You can update Nginx's configuration, and increase the number of PHP processes:

    1. Add these to nginx.conf (Menu > Nginx > nginx.conf), below client_max_body_size ... line
    http {
            .....
            fastcgi_buffers 8 128k;
    	fastcgi_buffer_size 128k;
    	fastcgi_connect_timeout 600;
    	fastcgi_send_timeout 600;
    	fastcgi_read_timeout 600;
    }
    
    1. Increase the number of PHP processes: Add this below [nginx] section in usr\laragon.ini (Menu > Laragon > Settings file: laragon.ini):
    [nginx]
    Upstream=20
    ...
    
    1. Restart Nginx

  • | 287 points

    Also I experience that page loads are FAR slower when Xdebug is enabled. If @leokhoa's answer does not help try disabling xdebug through Menu > PHP > Extensions > (disable) php_xdebug.dll

    Please give a feedback if anything helped.


  • | 380 points

    Hi tranks for the reply
    I have used this plugin (https://github.com/getdave/wp-intervention) to perform resizing of images but when making different sizes of images it seems the page was slow. Thanks for the tips @leokhoa and @MrSnoozles now its working


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.