Please a help with SSL connection (Chrome returns a NET::ERR_CERT_AUTHORITY_INVALID error)


  • | 2043 points

    Hi, I'm trying to use https:// to test development sites but I'm a bit stuck: Chrome tells me that "Connection is not private" with a "NET::ERR_CERT_AUTHORITY_INVALID" error code
    What I've done so far:

    • Preferences > Services & Ports > Apache SSL enabled (port 443)
    • Right-Click > Apache > SSL > Enabled (Auto-generate SSL Certificate is selected too)

    I can see my certificates in folder: C:\Laragon\etc\ssl

    And this is an example of what I have in C:\Laragon\etc\apache2\sites-enabled\auto.mysite.dev.conf:

    define ROOT "C:/Web/mysite/"
    define SITE "mysite.dev"
    
    <VirtualHost *:80> 
        DocumentRoot "${ROOT}"
        ServerName ${SITE}
        ServerAlias *.${SITE}
        <Directory "${ROOT}">
            AllowOverride All
            Require all granted
        </Directory>
    </VirtualHost>
    
    <VirtualHost *:443>
        DocumentRoot "${ROOT}"
        ServerName ${SITE}
        ServerAlias *.${SITE}
        <Directory "${ROOT}">
            AllowOverride All
            Require all granted
        </Directory>
    
        SSLEngine on
        SSLCertificateFile      C:/Laragon/etc/ssl/mysite.dev.crt
        SSLCertificateKeyFile   C:/Laragon/etc/ssl/mysite.dev.key
    
    </VirtualHost>
    

    Is there anything I'm missing?
    Thanks a lot :-)


  • administrators
    | 94231 points

    You can check @Kurre's answer here:
    https://forum.laragon.org/topic/106/laragon-and-let-s-encrypt/3


    But your browser is nagging about untrusted certificate :disappointed:
    You need to add it as trusted certificate...In Chrome go to chrome://settings :arrow_right: Advanced settings :arrow_right: HTTPS/SSL :arrow_right: Manage certificates
    Now we need to import newly created certificate to Chrome's certificate store
    Select import and select app.dev.crt file which you created earlier
    Important: Now you need to select the certificate store where you want to store this certificate.
    Select Place all certificates in the following store and to Certificate Store: select Trusted Root Certification Authorities
    Click Finish/OK and restart your browser. Now you can browse to https://app.dev without browser nagging about the certificate :)

    Hopefully you can get certificates working with this method..I wrote this text in a little rush, so please ask if you have some problems


  • | 34 points

    If your running nginx do the following :
    Right click ->Nginx -> SSL ->Add Laragon .crt to trust store
    reload the server.
    (worked for me).


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.