Quick create freezes on/after download on Laragon Wamp 3.1


  • | 1022 points

    Hi! Not all the predefined quick create projects work for me. What happens is that the database gets created, but then there is no progress on the download bar, even if the file has finished downloading and can always be found in laragon/tmp/downloads. The quick create process does not continue to extraction.

    This problems occurs for projects based on these archives:

    The strange thing is that it always works fine for these projects:

    The archives behave the same way (same problems / success per archive) if I upload them to my own server, which makes me believe it is related to the archive file size. The files that do not work are all more than 10mb, while the ones that do work are 8,5mb and 4,10mb.

    I'm running Windows 10.


  • administrators
    | 69033 points

    @torb: I'll check and get back to you.


  • | 1022 points

    @leokhoa: cool.
    In case i can help out to debug: is the script for quick creation somewhere to be found among the Laragon files and running off the server, or is it compiled onto the exe or a dll? It seems i'm hitting a 10mb limit somewhere, but haven't found anything in any conf file.


  • administrators
    | 69033 points

    FYI, the Quick Create is complied to laragon.exe
    I've checked with a Windows 10 with Joomla and it worked.
    Please check your Firewall, AV as I think it is something related to your OS/Network.


  • | 1022 points

    I'm experiencing the same issues with both Firewall and AV turned off. Also running Laragon with admin rights does not help. Running in windows 8 compatibility mode neither. But since it works for you it must be system related somehow.

    It does not matter if the file is coming from the network or from disk, so it probably is not network related. Also the file does get downloaded (or copied, if it is from disk), the progress is just not picked up by the quick create process whenever the file is more than approx 9.7mb (any file up to at least 9.6mb works - 9.8mb does not). All variables related to the zip file can be the same (zipper used, compression level, etc.) - just the total size matters.

    Also tried to download 3.0.5, but having the same issues there.

    Well, I'll give up and just make my projects manually out from a blank project. But a search in this forum shows that a small amount of users may have the same problem.


  • administrators
    | 69033 points

    @torb : Do you have links on the forum which are related to the same problem. I tested on many OSes (Windows 7, 8, 2012, 2016 ) + (both Cloud and different laptops) + (different networks) but could not reproduce the issue.


  • | 1022 points

    Sure!

    #1
    https://forum.laragon.org/topic/315/quicky-create-a-web-site-with-joomla-does-not-work/4

    User says .zip does not work, but tar.gz works. Zip for that release happened to be 11.8mb while the tarball was 8.29mb.

    #2
    https://forum.laragon.org/topic/438/git-clone-quick-project/3

    Very vague, but could be related. User just says that the zip (unknown size) does not work, but then disappears from conversation.


  • administrators
    | 69033 points

    @torb : Thanks for the links. I've re-checked them and you might right but I could not re-produce it. Aiza :(


  • | 1022 points

    @leokhoa: No problem, I find it easy to use Laragon even without this feature. I love how I just need to make a new directory in the www folder to get virtual hosts and ssl certificates set up.

    I'll post back if I figure out what is up with my system.

    Perhaps in the future you could release a testing version which logs possible exceptions thrown in the application.


  • | 165 points

    @torb: I had the same problem. If the file size is bigger, then laragon can't download it.
    I have a solution, but it's probably not the best.
    Download the file then decompress it. Decompressed drupal folder (v 8.3.7.) is 52 MB.
    Then I compressed it with 7-zip (with winrar and winzip would be too big: 15-20 MB). It is now 8,5 MB.
    I put the new compressed file in the c:\laragon\usr folder and I changed in the c:\laragon\usr\sites.conf file the Drupal 8 line from Drupal 8=https://ftp.drupal.org/files/projects/drupal-8.3.2.tar.gz to Drupal 8=C:/laragon/usr/drupal-8.3.7.7z.
    Now I can create drupal website with quick create.
    I hope it helps.


  • | 17 points

    I Have the same problem with prestashop. Have you got find a solution ?


  • | 1022 points

    @letyo: yes, I tried something similar, but for me the point of quick create is to get the latest version of the cms. As that did not work, I settled for manual download and creating a new folder in /www . Laragon automatically sets up virtual hosts and ssl when i restart the server, so it is pretty convenient.

    @thomasdominic : sorry, i did not find a solution on the machine with issues, but i've had it working on another machine, but with conciderable delay (several minutes) in the extraction process, see details below.

    @leokhoa : FYI: i'm using laragon as a portable installation, moving it around on an external ssd. I just tried it on a surface pro 4 with the same version of Laragon as before and now it worked! But it was slow. Download and unpacking went fine and quick in just a few seconds, then it was stuck at 0% extraction for about two minutes, jumped to 33% for about two minutes, same with 67%, then to 100%. About 6 minutes total for extraction. Anyway, no big deal-breaker for me :)


  • | 717 points

    found out having the same issue... whenever the file is larger than just under 10mb (latest WordPress zip is 9.9mb according to the website), it downloads but that's about it.

    Also when still using the zip, the download progress bar doesn't move at all but the file is actually downloaded to tmp/downloads

    Changed the quick create config to use the tar.gz file which is slightly smaller at 9.2mb, it works fine.

    Running latest Windows 10 Insider build and a fresh install of Laragon.


  • | 717 points

    Reproduced the problem on my desktop running the same Windows 10 build as my laptop...

    Are the other people in here ( @torb , @thomasdominic & @letyo ) by any chance also running Windows 10 Insider builds? I'm running 17046 which isn't the Fall Creators Update anymore but new build for RS4.

    @leokhoa did you get any smarter about this issue? If I can provide any logfile or so that would help, I'll gladly do so... Like Laragon too much to go find something else ;)


  • | 717 points

    Just updated to 3.2.0 but no difference alas... :(


  • administrators
    | 69033 points

    @hans-swolfs : Strange issue. I'll check and fix it soon.


  • | 717 points

    Cheers! If you need any info, let me know 👍
    @leokhoa said in Quick create freezes on/after download on Laragon Wamp 3.1:

    @hans-swolfs : Strange issue. I'll check and fix it soon.


  • administrators
    | 69033 points

    @hans-swolfs : I still have no clue. I've updated Wordpress package to tar.gz to sort it out temporarily.


  • | 717 points

    I'm going to setup a virtual machine with the regular Windows 10 Fall Creators Update to see if that helps...

    If needed, I'll have to revert from getting Windows Insider builds and remain on normal production :(


  • | 717 points

    Same thing here on a fresh Windows 10 Fall Creators Update install... Really strange stuff...

    Can it help when I say that the "download" progress bar remains grey even while the file is downloaded to the tmp folder?
    It starts extracting, creates the project folder under tmp\extract but that remains empty...


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.