Add country code to laragon windows


  • | 350 points

    So I want to use country specific domains and subdomains. But it doesn't work, subdomains alone without the country code work (once I remove all the country code specific code).

    I have restarted laragon and the dns service.

    Acrylic DNS Hosts file:

    127.0.0.1 *.listing.dev.au
    127.0.0.1 listing.dev.au
    

    Here is my nginx file modified (with the auto prefix removed):
    listing.dev.au.conf

    server {
        listen 80;
        server_name listing.dev.au *.listing.dev.au;
        root "C:/laragon/www/listing/public/";
        
        index index.html index.htm index.php;
     
        location / {
            try_files $uri $uri/ /index.php$is_args$args;
        }
        
        location ~ \.php$ {
            include snippets/fastcgi-php.conf;
            fastcgi_pass php_upstream;		
            #fastcgi_pass unix:/run/php/php7.0-fpm.sock;
        }
    	
    	
        charset utf-8;
    	
        location = /favicon.ico { access_log off; log_not_found off; }
        location = /robots.txt  { access_log off; log_not_found off; }
        location ~ /\.ht {
            deny all;
        }
    }
    
    # This file is auto-generated.
    # If you want Laragon to respect your changes, just remove the [auto.] prefix
    # If you want to use SSL, enable it by going to Menu > Nginx > SSL > Enabled
    
    

  • administrators
    | 58901 points

    @tbss: What error when "it doesn't work"?


  • | 350 points

    Normally error when the dns lookup fails "page does not exist". Same as if you go to a domain that doesn't exist: http://fadsafdsafdsafijbhrgsaijbrgaijbgfsaijbfdsaijbfdsiubfdsaijubfdsa.com/


  • administrators
    | 58901 points

    @tbss: The failure of DNS means Acrylic doesn't work. You may check by ping blah.listing.dev.eu

    How about using hosts file (not support wildcard but just for testing)?


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.