Wordpress in laragon


  • | 373 points

    Hi, I want to install the wordpress locally with Laragon. I used quick create and installed a fresh Wordpress in WWW directory. But when I go to wordpress_Goodnews.dev in my browser it doesn't show any thing:

    This page isn’t working
    wordpress_Goodnews.dev didn’t send any data.

    What should I do?
    Thanks


  • administrators
    | 115151 points

    @mamad86 : What is actually the name of the project you created? wordpress or wordpress_first?
    Some images will be helpful.


  • | 373 points

    The name is correct. I just installed wordpress with laravel quick create and directory is created. How can I run it? clicking on Menu->www->wordpress_Goodnews direct me to wordpress_Goodnews.dev in my browser. Image for what part?!

    browser_image


  • administrators
    | 115151 points

    @mamad86 : Creating Wordpress site is easy. Here's how:

    1. Click Menu > Quick create > Wordpress
    2. Choose a name, such as mysite
    3. Laragon will download Wordpress, unzip and put it to www\mysite. It also create a database name mysite.

    Then, you'll have a Wordpress site at: http://mysite.dev
    That's all.


  • | 373 points

    @leokhoa
    I exactly did these steps but I got the page in the picture...


  • administrators
    | 115151 points

    @mamad86 : I wonder what is using port 80. I don't think the result is coming from Laragon. Can you try:

    1. Find out which program is using port 80 by using Menu > Tools > netstat
    2. ping mysite.dev and give me the result.

  • | 373 points

    @leokhoa

    TCP 0.0.0.0:80 0.0.0.0:0 LISTENING 5836
    C:\laragon-apachi-2.2.2_FULL\bin\apache\httpd-2.4.25-win32-VC14\bin\httpd.exe


  • administrators
    | 115151 points

    @mamad86 : It's the Apache in Laragon. Very strange. I think you may go with Nginx.


  • | 373 points

    @leokhoa
    Laravel works fine and problem is with wordpress. In laravel I use php artisan serve and localhost:8000 and clicking on Web button in Laragon does not work(it directs me to localhost:8080). Maybe I should change some configuration.


  • | 36 points

    @mamad86
    I had the same problem. My solution was to replace _ (underscore-sign) with something else (like -) in the folders name.
    Hope it helps.


  • | 373 points

    @DPSchn
    Thanks, but it didn't solve the problem.


  • | 1041 points

    Have you changed any settings during or after the install? I wonder if uninstalling and reinstalling using the defaults would work? What a puzzle. Sorry you are having a hard time.


  • | 11 points

    @DPSchn Your solution worked for me. Thanks!


  • | 1048 points

    I had a Wordpress website where I integrated WordPress and Laravel with Google Doc to automatically import content from Doc to WP draft. Is it possible to do the same with laragon and WordPress?


  • | 1041 points

    @olivedev - In the article you link to they are using the Laravel framework. Laragon is a different thing. It makes available the PHP (Python and/or NodeJS) languages. I imagine you could install Laravel and use the code you have from your previous project, tweak it, and get it to work with local Laragon. That is not something I've done, so I might not be much help.

    In case it is useful, here is an article that goes over a number of other ways of using Google Docs and WordPress (none perhaps as easy as what you used to do):

    https://kinsta.com/blog/google-docs-to-wordpress/

    Best,

    David


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.