Avoid Site access with url.dev:8888/ with Nginx


  • | 471 points

    Hi, everyone

    I prefer Nginx over Apache, how can I avoid the port:8888 on the url when accessing my local sites?
    because when I was using Apache it don't have to access the site with the {port-address}.

    Such an example:
    Curiosity.dev/ (Apache)
    Curiosity,dev:8888/ (Nginx)

    How to solve this?

    Thank You Everyone!


  • | 5190 points

    @pramanadiputra

    To solve your problem what you can do is:

    01. Open the Laragon window and select Preferences:

    0_1514264754297_upload-fd7e6767-a24a-4efa-bffd-0290e58c46f5

    02. Select Services & Ports section and swap the ports of Apache and Nginx:

    0_1514264826373_upload-c3ff2246-961b-4343-8eef-5592b793fe5c

    As you want your Nginx sites to be accessed normally without specifying port number, you should swap the normal and SSL port numbers of the apache and Nginx settings.

    I hope this will solve your problem.
    šŸ˜Š


  • | 471 points

    @bantya How it's just a matter of swapping the port between them. I'll try it later.

    Thank You Very Much for your time :) Greeting from Bali


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.