Pretty URL is serving root issue


  • | 591 points

    Hi. I experience a weird issue here. I am using Laragon fine for over 20 projects. Then recently added a new project using Quick Start as usual, the pretty URL no longer working. It serves the document root(G:/laragon/www for my case) instead of the project directory(G:/laragon/www/app). I tried two more new projects and got the same result. I have checked the auto.{project}.test.conf and compared it with the other old projects. They look the same.

    I have experienced it once before. I updated Laragon and the issue gone. But now, the issue comes back.

    (I like Laragon a lot. Thank you so much for your work!)


  • administrators
    | 82333 points

    @karltdev : What type of your project (Wordpress,...) ?
    Can you also show me the content of auto.{project}.test file?


  • | 591 points

    Hi @leokhoa , I normally use Quick Create>Wordpress, but my project is not using wordpress. I use either some static files or Processwire. I go straight to the pretty URL after the Quick Create finish. I tried using other type like Drupal and get the same result.

    I just create another one for testing using Quick Create>Drupal. Below is the auto.try.test file. This project's pretty url is serving document root too.

    define ROOT "G:/laragon/www/try/"
    define SITE "try.oo"
    
    <VirtualHost *:80> 
        DocumentRoot "${ROOT}"
        ServerName ${SITE}
        ServerAlias *.${SITE}
        <Directory "${ROOT}">
            AllowOverride All
            Require all granted
        </Directory>
    </VirtualHost>
    
    <VirtualHost *:443>
        DocumentRoot "${ROOT}"
        ServerName ${SITE}
        ServerAlias *.${SITE}
        <Directory "${ROOT}">
            AllowOverride All
            Require all granted
        </Directory>
    
        SSLEngine on
        SSLCertificateFile      G:/laragon/etc/ssl/try.oo.crt
        SSLCertificateKeyFile   G:/laragon/etc/ssl/try.oo.key
     
    </VirtualHost>
    

    Note: my old projects are working fine. The pretty URL is still serving correctly.


  • administrators
    | 82333 points

    @karltdev : The Document Root is correct. I found that the domain is {name}.oo but the auto generated virtual host file is auto.{name}.test (it should be auto.{name}.oo.conf)

    Can you try to change the hostname format to something else (in Menu > Preferences)?


  • | 591 points

    Ah, sorry, it should be auto.try.oo.conf. I overlooked the name. Hostname right now is {name}.oo, which I changed from {name}.dev when google took away .dev.


  • | 591 points

    I re-install laragon-wamp.exe. This solves the issue again.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.