Wordpress not launching and getting 'Server Not Found' page.


  • | 941 points

    After wordpress quickstart, when I launch the website to setup wordpress I am getting a Server Not Found page. I can open the localhost page with Laragon logo.

    I don't know if this is related to wordpress not launching but I noticed that my laragon gui looks different than the one on the docs page (https://www.laragon.org/docs/). I have the Apache and MySQL on the gui but I am missing the Nginx, Redis, and Memcached.


  • | 1187 points

    @affirmallchance have you tried restarting Laragon?


  • | 941 points

    Yeah, I tried restarting and reinstalling. I installed the PHP 1. Laragon Wamp, but I do not have Nginx, Redis, and Memcached on the gui. Is that a problem?

    I tried putting my www/mysite in the host file and got "Error establishing a database connection" on the webpage.

    Also this is my Mysqld.log:

    2018-04-28T09:29:56.297121Z 0 [Warning] Insecure configuration for --secure-file-priv: Current value does not restrict location of generated files. Consider setting it to a valid, non-empty path.
    2018-04-28T09:29:56.297121Z 0 [ERROR] Cannot open Windows EventLog; check privileges, or start server with --log_syslog=0
    2018-04-28T09:29:56.297121Z 0 [Note] C:\laragon\bin\mysql\mysql-5.7.19-winx64\bin\mysqld (mysqld 5.7.19) starting as process 17560 ...
    2018-04-28T09:54:01.939261Z 0 [Warning] Insecure configuration for --secure-file-priv: Current value does not restrict location of generated files. Consider setting it to a valid, non-empty path.
    2018-04-28T09:54:01.940264Z 0 [ERROR] Cannot open Windows EventLog; check privileges, or start server with --log_syslog=0
    2018-04-28T09:54:01.940264Z 0 [Note] C:\laragon\bin\mysql\mysql-5.7.19-winx64\bin\mysqld (mysqld 5.7.19) starting as process 19216 ...
    2018-04-28T10:25:53.967796Z 0 [Warning] Insecure configuration for --secure-file-priv: Current value does not restrict location of generated files. Consider setting it to a valid, non-empty path.
    2018-04-28T10:25:53.967796Z 0 [ERROR] Cannot open Windows EventLog; check privileges, or start server with --log_syslog=0
    2018-04-28T10:25:53.967796Z 0 [Note] C:\laragon\bin\mysql\mysql-5.7.19-winx64\bin\mysqld (mysqld 5.7.19) starting as process 17292 ...
    2018-04-28T10:46:13.112345Z 0 [Warning] Insecure configuration for --secure-file-priv: Current value does not restrict location of generated files. Consider setting it to a valid, non-empty path.
    2018-04-28T10:46:13.112345Z 0 [ERROR] Cannot open Windows EventLog; check privileges, or start server with --log_syslog=0
    2018-04-28T10:46:13.112345Z 0 [Note] C:\laragon\bin\mysql\mysql-5.7.19-winx64\bin\mysqld (mysqld 5.7.19) starting as process 4612 ...


  • | 1187 points

    @affirmallchance in theory that's not a problem.

    if you got an error stabilishing database connection, its a problem with config file from wordpress.

    You need check inside your local project folder, and open "wp-config.php" and check:

    db_name: the database name that you set in instalation (in first step for automatic Wordpress installer from Laragon). You can view your databases with heidisql (right click on Laragon taskbar icon / mysql / heidisql) and click on open.

    db_user: root

    db_pass: leave empty (only quotes)

    db_host: localhost


    For your first problem (server not found):

    note: if you now get error stabilishing database connection, now you do not have the problem with server not found. Server now works.

    you need check php port, and set to 80 (right click on laragon taskbar icon / preferences / ports).

    close Laragon and re-run with admin privileges (right click on Laragon desktop icon and run as administrator).

    P.D.: you can always use the full version for discard other problems (you can activate and deactivate services in preferences. Laragon is easy!)


  • | 941 points

    I don't see a field for php port, but is this ok?
    Also, like you say, when I goto wp-admin/install.php from the readme file, it says "Error: PHP is not running
    WordPress requires that your web server is running PHP. Your server does not have PHP installed, or PHP is turned off."

    Thank you for helping me. I am not a technical person, but I followed the install instructions so I am confused.

    0_1524919154172_No-PHP.PNG


  • | 1187 points

    @affirmallchance are you sure to have checked all options in General tab
    0_1524920347594_options.jpg

    close Laragon and re-run

    edit: you're options are good. The port 80 is used for apache or nginx (not for PHP, sorry).
    after you restart Laragon with all checked in general tabs, if not work, test with uncheck Apache, and check Nginx, and invert the ports (apache:8080 and 8443 // and remember uncheck // Nginx: 80 and 443 // and remember check).

    Normaly this problems not ocurred, so only test options. If you cannot make it work, write to me privately and I'll solve it.


  • administrators
    | 93527 points

    @affirmallchance :
    Mostly Laragon doesn't need Administrator right to run but this line make me think about permissions.
    Can you try to run Laragon as Administrator?

    [ERROR] Cannot open Windows EventLog; check privileges, or start server with --log_syslog=0
    

  • | 941 points

    @leokhoa I think you may be right. I am signed in as an administrator and also running Laragon as administrator but when I turn on the 'auto virtual hosts' I am getting this warning. I am confused since I am not only signed in as Admin but also running Laragon as Admin.
    0_1524988261480_laragon-virtualhost-warning.PNG


  • administrators
    | 93527 points

    @affirmallchance : The file permissons look good to me. Do you have any AV program running?
    If yes, please whitelist Laragon.


  • | 941 points

    @leokhoa Yes! I got it working. It was a Korean security program called Ahnlab that was blocking the host file making localhost inaccessible. This is a popular security app in Korea so hopefully other Koreans having this issue can find this thread and solve their issues.

    Thank you so much for your insight! I also want to thank @condemned for taking the time and offering assistance. This is a very good forum and support!


  • | 1187 points

    @affirmallchance :) happy develop


  • administrators
    | 93527 points

    @affirmallchance: You're welcome! I'm glad to know the issue sorted and Ahnlab program is the root cause of the issue. I believe your information will help many other Koreans.
    Cheers!


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.