SSL not working


  • | 568 points

    Hello,

    When I discovered Laragon I was happy from the features it offers but while minutes and hours goes by, my feeling started to change from happy to angry... sorry to say that but I'm somehow disappointed.

    I'm having issues running projects with SSL.
    First, Chrome/Firefox/Opera .. all denies the access as they don't trust the certificate provided with the website and I'm getting an error like :"This site can’t provide a secure connection
    laravel.dev sent an invalid response.
    Try running Windows Network Diagnostics.
    ERR_SSL_PROTOCOL_ERROR"

    and sometimes an issue with HSTS etc....

    I then had issues with Nginx / Apache starting web server, Nginx says port 80 is in use, skype is uninstalled and same issue is thrown, Apache says can't bind 443 to the host which confusing... I ended up changing web port to 8080 and ssl to 4443 and I still want to use port 80/443 but how?

    I tried to use HTTP only without SSL, every website is trying to lookup for HTTPS://...

    I need your help please


  • administrators
    | 92633 points

    Haha, you're wrong about Laragon @Zack-Tim :) It's Google who decided to force https on .dev domain.
    https://ma.ttias.be/chrome-force-dev-domains-https-via-preloaded-hsts/

    To fix it, just change the hostname format in Menu > Preferences to:
    {name}.test

    Also, to figure out which program is using port 80, use Menu > Tools > netstat


  • | 568 points

    Thanks for your reply.

    I found that information yesterday and I changed dev to test as you said but there is no effect, check screenshot0_1526125154163_Capture_2.JPG


  • administrators
    | 92633 points

    @Zack-Tim : Your image doesn't relate to .dev issue. It is related to ports issue. Did you follow my instruction to figure out which program is using port 80/443?

    Also, to figure out which program is using port 80, use Menu > Tools > netstat


  • | 568 points

    I have this:

    TCP 127.0.0.1:80 127.0.0.1:56505 TIME_WAIT 0
    TCP 0.0.0.0:443 0.0.0.0:0 LISTENING 5580

    What do you see from this output cause i'm not seeing anything useful, the issue with the port shows up only when I let HTTPS to 443, when I change it to something like 8443 laragon works fine...


  • administrators
    | 92633 points

    @Zack-Tim : Some programs occupy ports 80 and 443 and you don't know. If netstat can't help you figure out, I can't help you further.


  • | 568 points

    Some programs occupy port 80 and 443 like which one so I can check them one by one?

    I'm not the only having this issue, others are having same problem if you look closely in the forum


  • | 568 points

    I found the solution, it was vmware that is taking port 443

    To Resolve it

    Go to menu Edit -> Preferences -> Shared VMs and click on "Disable Sharing".

    And by the way the command for netstat is not complete, it should be netstat -a -b

    Hope this help others


  • administrators
    | 92633 points

    @Zack-Tim : I'm glad you found the issue. However, if you followed my instruction which I mentioned many times, the issue would be sorted earlier:

    Also, to figure out which program is using port 80, use Menu > Tools > netstat

    Instead of usinh Menu > Tools > netstat of Laragon, you typed netstat?


  • | 568 points

    thank you.

    Yes I typed netstat - a -b

    For some reasons, Menu -> Tools -> netstat didn't show me the exact process that was using port 443, i had to run it with administrator privilege I guess...

    Thank you for this beautiful software [Laragon]

    One last question: do you have any plans to make same application for linux users so we can run it on linux?

    Thank you


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.