Your connection to this site is not Secure , strikethrough https


  • | 634 points

    Goodday,

    Hi, i try to migrate a site to local production using backupbuddy.
    Everything was fine till i tried to use backupbuddy deployment to pull/push from 'Live' to 'Local'
    Error;
    "cURL error 60: SSL certificate problem: self signed certificate"

    I suspect its https issue.

    I had Installed laragon-wamp. 7.1.14
    In laragon, i have set Apache -> SSL -> Enable
    -> Auto generate SSL Certificate.

    Sites-enabled, there is -> auto.starter.test.conf

    Does anyone have any solutions for this?
    Had tried to search the forum, but can't find any solutions.


  • | 634 points

    Finally solved the https issue.
    By creating a makeCERT.Bat
    Solution by kaxias.
    https://forum.laragon.org/topic/770/update-auto-generated-ssl-certificates/5

    It took me half a day to understand it.
    example
    REM PLEASE UPDATE THE FOLLOWING VARIABLES FOR YOUR NEEDS.
    SET HOSTNAME=domain (Your domain, ie folder in www->)
    REM DOT= com DOT= dev DOT= test DOT= it
    SET DOT=com (change to test, default is test)
    SET COUNTRY=UK
    SET STATE=WY
    SET CITY=Halifax
    SET ORGANIZATION=IT
    SET ORGANIZATION_UNIT=IT Department
    SET EMAIL=administrator@%HOSTNAME%.%DOT%

    In Laragon, Right Click -> Apache -> sites-enabled -. Delete all [auto] or your current site.

    Go to 'Terminal' -> Navigate to laragon/etc/ssl (cd laragon/etc/ssl)-> Run makeCERT.bat
    Stop & Start all - Apache (don't just reboot)

    Import the generated certificate from laragon/etcs/ssl to Chrome setting (Run as administrator & delete previous similar cert if any)
    -> Advanced -> Managed Certificate -> import
    Browse from laragon/etcs/ssl , Place in Trusted Root Certification Authorities NOT inside Personal.

    Close & restart Chrome.

    That's how i got it working, for the Secure Https portion.

    But now i got another error.
    Error #84379794322337894: Missing expected default state override. Options: Array ( [bb_version] => 8.2.5.0 (downloaded 2018-05-17T05:34:51+00:00) [backup_directory] => [log_level] => 0 [log_serial] => 82sa2k8vc2oe4os ).

    Though i think this is probably from backupbuddy side.
    https://ithemes.com/backupbuddy/wordpress-staging/

    hope it helps


  • | 634 points

    oh, i disable/untick the below portion.
    Apache -> SSL -> Enable
    -> Auto generate SSL Certificate.


  • | 634 points

    Totally give up on backupbuddy.

    Current setup
    Laragon (Local) using wpsitesync(free) to sync to Live.
    wpsitesync sync only posts content.

    Anyone mind sharing how you push your staging WP to Live WP?
    Any alternative beside backupbuddy for staging to live.(https://ithemes.com/backupbuddy/wordpress-staging/)


  • | 420 points

    "Anyone mind sharing how you push your staging WP to Live WP?"

    I've used the All in One WP Migration plugin (free for database up to 512MB) and UpdraftPlus with its paid Migrator add-on.

    Things that I've found that help make the process smoother are to turn off caching plugins before taking the backup and sometimes turn off security plugins on the source and/or target before the actual migration. If you use a page builder it seems that the caching can sometimes be an issue. Occasionally I've had the security plugins cause an issue when logging in after the migration (you can also disable them via FTP is you have an issue).


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.