phpMyAdmin Import/Export Woes (latest, WordPress installs)


  • | 296 points

    What's crackin', folks
    I switched from WAMPserver to Laragon like a month ago and so far I really love it. Simple, fast. I exclusively use it for Wordpress development and it does the thing.

    Since I got a new laptop, I'm moving things around between my desktop, old laptop, and new laptop. When I migrated my databases from my old WAMPserver install, it pretty much didn't take any of them. I think only one or two sites's dbs got successfully imported and I figured I'd just rebuild as needed.

    So, when trying to update and work on one site in particular, I just can't seem to get my production db imported. It seems like there's some kind of config difference between standard phpmyadmin installs on most hosting (and WAMPserver) and the default settings Laragon is using with phpmyadmin. I get the "Incorrect format parameter" error anytime I try to import a standard SQL file from another instance of phpmyadmin.

    Backend isn't my strong suite so I'm in a bit over my head with this. I know this isn't strictly a Laragon issue, but has anyone here had weird issues with exporting and importing dbs to and from other phpmyadmin installs on WAMPserver or hosting company installs?


  • administrators
    | 94205 points

    @tetractys : Sorry for my late response. I did not notice it. Are your db in production and in Laragon the same version?


  • | 107 points

    Maybe try using the mysql command line instead of phpmyadmin. Here are some instructions:

    https://webcheatsheet.com/sql/mysql_backup_restore.php


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.