Announcement on Forum says 3.3 released, but I am using 3.4. Is there a more current version?