Hi, I'm using Laragon 4.0 Full, Win 10, which FYI is working perfectly for WP installs.

I'm also attempting to clone a non-WP repo from GitHub but I'm getting the following error: "error: cannot spawn git: Invalid argument" after using the git clone command.

I created a 'blank' Quick App using Laragon.
Then in Cmder:
bash
cd testsite
git init
.. Initialized empty Git repository in C:/laragon/www/GITTEST/.git/
git clone https://github.com/atom/github.git
.. Cloning into 'github'...
.. error: cannot spawn git: Invalid argument

Can somebody explain the easiest way to clone a GitHub repo using the GIT that comes with Laragon?

Thanks.

P.S. Could it be anything to do with the Paths settings in Tools / Paths / Manage Paths? Mine seem strange with a semi-colon on its own at the top and one missing near the bottom (after VSC), along with some of my paths repeated:

--------------- Laragon ---------------
;
C:\laragon\bin;
C:\laragon\bin\apache\httpd-2.4.35-win64-VC15\bin;
C:\laragon\bin\composer;
C:\laragon\bin\git\bin;
C:\laragon\bin\git\cmd;
C:\laragon\bin\git\mingw64\bin;
C:\laragon\bin\git\usr\bin;
C:\laragon\bin\laragon\utils;
C:\laragon\bin\mysql\mariadb-10.3.10-winx64\bin;
C:\laragon\bin\nginx\nginx-1.14.0;
C:\laragon\bin\ngrok;
C:\laragon\bin\notepad++;
C:\laragon\bin\php\php-7.2.11-Win32-VC15-x64;
C:\laragon\bin\putty;
C:\laragon\bin\redis\redis-x64-3.2.100;
C:\laragon\bin\telnet;
C:\laragon\usr\bin;
C:\Users\John King\AppData\Local\Yarn\config\global\node_modules.bin;
C:\Users\John King\AppData\Roaming\Composer\vendor\bin;
C:\Users\John King\AppData\Roaming\npm;

--------------- User ---------------
C:\laragon\bin;
C:\laragon\bin\apache\httpd-2.4.35-win64-VC15\bin;
C:\laragon\bin\composer;
C:\laragon\bin\git\bin;
C:\laragon\bin\git\cmd;
C:\laragon\bin\git\mingw64\bin;
C:\laragon\bin\git\usr\bin;
C:\laragon\bin\laragon\utils;
C:\laragon\bin\mysql\mariadb-10.3.10-winx64\bin;
C:\laragon\bin\nginx\nginx-1.14.0;
C:\laragon\bin\ngrok;
C:\laragon\bin\notepad++;
C:\laragon\bin\php\php-7.2.11-Win32-VC15-x64;
C:\laragon\bin\putty;
C:\laragon\bin\redis\redis-x64-3.2.100;
C:\laragon\bin\telnet;
C:\laragon\usr\bin;
C:\Users\John King\AppData\Local\Yarn\config\global\node_modules.bin;
C:\Users\John King\AppData\Roaming\Composer\vendor\bin;
C:\Users\John King\AppData\Roaming\npm;
C:\Users\John King\AppData\Local\Microsoft\WindowsApps;
C:\VSC\bin

--------------- System ---------------
C:\Windows\system32;
C:\Windows;
C:\Windows\System32\Wbem;
C:\Windows\System32\WindowsPowerShell\v1.0;
C:\Windows\System32\OpenSSH;
C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common