I recently installed Laragon and updated php to 7.VC15 x64 TS and updated MySQL to 8.0.18 winx64 However MySQL fails to start. The error log shows the following:

2019-10-25T19:25:57.983319Z 0 [ERROR] [MY-010735] [Server] Could not open the mysql.plugin table. Please perform the MySQL upgrade procedure.
2019-10-25T19:25:58.535346Z 0 [Warning] [MY-010015] [Repl] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
2019-10-25T19:25:58.924966Z 0 [Warning] [MY-010015] [Repl] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
2019-10-25T19:25:59.026855Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2019-10-25T19:25:59.031943Z 0 [Warning] [MY-010441] [Server] Failed to open optimizer cost constant tables
2019-10-25T19:25:59.033424Z 0 [ERROR] [MY-013129] [Server] A message intended for a client cannot be sent there as no client-session is attached. Therefore, we're sending the information to the error-log instead: MY-001146 - Table 'mysql.component' doesn't exist
2019-10-25T19:25:59.035749Z 0 [Warning] [MY-013129] [Server] A message intended for a client cannot be sent there as no client-session is attached. Therefore, we're sending the information to the error-log instead: MY-003543 - The mysql.component table is missing or has an incorrect definition.
2019-10-25T19:25:59.039508Z 0 [ERROR] [MY-010326] [Server] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist
2019-10-25T19:25:59.041000Z 0 [ERROR] [MY-010952] [Server] The privilege system failed to initialize correctly. For complete instructions on how to upgrade MySQL to a new version please see the 'Upgrading MySQL' section from the MySQL manual.
2019-10-25T19:25:59.047275Z 0 [ERROR] [MY-010119] [Server] Aborting
2019-10-25T19:26:00.287089Z 0 [System] [MY-010910] [Server] C:\laragon\bin\mysql\mysql-8.0.18-winx64\bin\mysqld: Shutdown complete (mysqld 8.0.18) MySQL Community Server - GPL.

I thought that I should be able to easily switch between MySQL/MariaDB versions. Apparently I was wrong.

Any help will be greatly appreciated