auto virtual hosts only working on IE while redirecting to https and not working on other browsers


  • | 258 points

    First, thanks so much for the really great Laragon. Idk how I didn't find it long before !

    Everything is working great except for this issue I had today when I decided to try the auto virtual hosts. I updated today to the latest Laragon 3.3. I enabled auto virtual hosts but didn't touch the ssl options.

    When I go to http://mysite.dev it redirects to https://mysite.dev and on Firefox gives me "Firefox can’t establish a connection to the server at mysite.dev" and same on Opera and Chrome while it works fine on IE and without re-directing to https.

    1. Why redirecting to https (which I didn't enable) except on IE (no redirecting)
    2. Why not working on other browsers. I guess it's because it's redirecting to https :-/

    Of course, when I have proxy connected no browser works at all and I understand from a post I read on this forum that pretty urls wont work when using a proxy.

    I appreciate your help so much


  • administrators
    | 97034 points

    @mmonli : Laragon does not redirect http to https on .dev domains - your browsers do. They called it HTTP Strict Transport Security (HSTS)

    To fix, just change the hostname format in Menu > Preferences to: {name}.test

    Ref:
    https://forum.laragon.org/topic/764/important-dev-domains-chrome-63


  • | 258 points

    wonderful. Thanks so much for the genuine support and sorry I didn't find the mentioned link before I posted.


  • administrators
    | 97034 points

    You're welcome! Cheers!


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.