Auto-generated SSL certificates not working


  • | 88 points

    Hi,

    I have the same problem as @brian2one0 . I havent "auto.openssl.conf" in my /etc/ssl folder. I just see "cacert.perm"

    I installed the last version of laragon-wamp

    Laragon Wamp: Apache 2.4, Nginx, MariaDB 10.3, PHP 7.2, Node.js 10, Redis, Memcached, yarn + ngrok, git…
    Download Laragon - WAMP (124 MB)

    0_1542795248927_upload-1b7d9c0d-d603-48c8-be06-e1128d0bb0dc


  • | 165 points

    I also cannot get Apache started with SSL. In the /etc/ssl folder, "cacert.perm" is the only file there.

    I am using Windows 10, with Laragon 4.0 installed.

    @Xermo10 said in Auto-generated SSL certificates not working:

    Hi,

    I have the same problem as @brian2one0 . I havent "auto.openssl.conf" in my /etc/ssl folder. I just see "cacert.perm"

    I installed the last version of laragon-wamp

    Laragon Wamp: Apache 2.4, Nginx, MariaDB 10.3, PHP 7.2, Node.js 10, Redis, Memcached, yarn + ngrok, git…
    Download Laragon - WAMP (124 MB)

    0_1542795248927_upload-1b7d9c0d-d603-48c8-be06-e1128d0bb0dc


  • | 8 points

    same thing to me.. please, help!


  • | 91 points

    I have solution for this case.. just copy file openssl. exe
    from apache directory to laragon utils directory..
    for example in my laptop, i copy :
    from C:\laragon\bin\apache\httpd-2.4.35-win64-VC15\bin\openssl.exe
    to C:\laragon\bin\laragon\utils\openssl.exe


  • administrators
    | 115330 points

    @brian2one0, @Xermo10 , @Sophy-Khon , @HAN-105 : Please follow @caesarali instruction to fix the issue.

    I have solution for this case.. just copy file openssl. exe
    from apache directory to laragon utils directory..
    for example in my laptop, i copy :
    from C:\laragon\bin\apache\httpd-2.4.35-win64-VC15\bin\openssl.exe
    to C:\laragon\bin\laragon\utils\openssl.exe

    I will make a hotfix soon.


  • | 39 points

    @caesarali
    Besides "openssl.exe" I had to copy "libssl-1_1-x64.dll" and "libcrypto-1_1-x64.dll".
    Thank you for your suggestion (and sorry for my bad english)


  • | 91 points

    @ribalto oh yea, sorry i forget for these file.. It must be copy too with the openssl.exe file..


  • | 88 points

    @leokhoa the issue is solved?


  • administrators
    | 115330 points


  • | 88 points

    Thanks @leokhoa !


  • | 617 points

    For future readers, I had the same problem, It's somehow related to having both apache and nginx with SSL enabled, when i start Nginx it won't create the cert nor the conf in /etc/ssl, then when i started apache which was listening on non 80/443 ports, it created the cert and i was able to start nginx after that.


  • | 337 points

    Yesterday, I had the same issue than brian2one0. Impossible to have an https://localhost working.
    My Laragon could not auto-generate the certificate, because it's the Lite version (windows 32 bit), so I found a way to do it myself, and I put the certificate in laragon/bin/apache/httpd-2.4.23-win32-VC11/conf/ssl/ and then activated the SSL (on port 443). I also changed the httpd-ssl.conf content to find the certificates (I followed a tutorial).
    But impossible to reach the pages. I was not sure what I was doing, so I chose to get back to my original statement, I "undo" the changes, and now nothing is working anymore.
    When I try to reach localhost, laragon is pointing to a directory in www and not in www, so strange. Now my all web site is not working because of this wrong pointing. I am downloading a new version of laragon, hope it'll work.


  • administrators
    | 115330 points

    @BenPix : Enabling HTTPs requires a lot of configurations. I hope Laragon helps you on that.


  • | 337 points

    I will try again with my new version, and post more information if it's interesting for the readers ;)


  • | 21 points

    I am in Computer science engineering, Auto-generated SSL certificates can be achieved by GPA Calculator , works very efficently and great learning process.


  • | 227 points

    @leokhoa I have laragon lite 4.0.12 installed and I'm trying to enable the SSL certificate but no success, I don't get any error messages even in the laragon.log file, any ideas?

    thanks


  • administrators
    | 115330 points

    @oleonides : How about Laragon's Full version?


  • | 227 points

    @leokhoa is there a way to migrate to the full version keeping my projects and databases?


  • administrators
    | 115330 points

    @oleonides : You can try:

    1. Backup your current laragon to C:\laragon.bak
    2. Setup Laragon Full over C:\laragon
      That should work.

  • | 227 points

    @leokhoa I've changed to the full version and the SSL certificate is working in chrome and edge but not in firefox.
    would it be possible to migrate to the full version definitely without creating again all my stuff?
    thanks for your help.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.