HTTPS on port 2211 or 8080?


  • | 495 points

    I have config apache listen on port 2211 and I enable SSL on port 443.
    This is my virtual host config:
    <VirtualHost *:2211>
    DocumentRoot "F:/Server/laragon/www/newton-site/public/"
    ServerName newtonsite.info
    ServerAlias *.newtonsite.info
    <Directory "F:/Server/laragon/www/newton-site/public/">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    Require all granted
    </Directory>
    </VirtualHost>

    If you want to use SSL, enable it by going to Menu > Apache > SSL > Enabled

    <VirtualHost *:443>
    DocumentRoot "F:/Server/laragon/www/newton-site/public/"
    ServerName newtonsite.info
    ServerAlias *.newtonsite.info
    <Directory "F:/Server/laragon/www/newton-site/public/">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    </Directory>
    SSLEngine on
    SSLCertificateFile "F:/Server/laragon/etc/ssl/newtonsite.info.crt"
    SSLCertificateKeyFile "F:/Server/laragon/etc/ssl/newtonsite.info.key"
    </VirtualHost>
    When keep port 2211 HTTPS not working but change it to 80. It is working.
    Please help me!
    0_1532626470675_upload-7c67a000-75ab-4548-80d8-5bc2d9f70e99
    0_1532626589118_upload-1d90aafe-842d-4d52-bf68-a36a1bbd7d16


  • administrators
    | 90764 points

    @Monster-Dragon : If you want to change ports, just change them in Menu > Preferences > Services and Ports


  • | 495 points

    I changed port follow your guide but not working when running HTTPS, my problem occurs when I run HTTPS on difference port with 80.
    Thanks @leokhoa


  • administrators
    | 90764 points

    @Monster-Dragon : It's because your Apache is listen on port 443 for https and 2211 for http.


  • | 495 points

    @leokhoa
    I understood the problem.
    Thanks for the support!


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.