Dealing with self signed certificates for live domains with suffix: .test


  • | 812 points

    I have noticed Laragon can create by default self signed certificates automatically.

    If I add a new virtual host, then, on the file file:

    ./etc/ssl/auto.openssl.conf
    

    the following content gets populated automatically at the end of the file:

    [alt_names]
    DNS.1 = localhost
    
    # You can another DNS below. For example:
    # DNS.2 = xxx
    # DNS.3 = yyy
    DNS.2=my-site-1.com.test
    DNS.3=*.my-site-1.com.test
    DNS.4=my-site-2.com.test
    DNS.5=*.my-site-2.com.test
    DNS.6=my-site-3.com.test
    DNS.7=*.my-site-3.com.test
    

    and the following files are generated automatically:

    laragon.crt
    laragon.csr
    laragon.key
    

    My problem is that if I get rid of the ".test" suffix on the domains above, then, only the domain: "localhost" is taken into consideration.

    Is any way I can get rid of those ".test" suffixes?

    Thanks!


  • | 812 points

    Also, another question, is here involved a "Root CA" certificate used to sign this self signed certificate?, so if I trust on that "Root CA" then I will consequently trust on next self signed certificates automatically?


  • administrators
    | 97623 points

    @toshiba :
    A1: I don't know why do you want remove the *.test as Laragon auto detect projects in your DocRoot and generate for you. However, if you only want localhost, the solution is easy: Just disable Laragon Auto Create SSL feature.

    A2: No, when the new cert is generated, Laragon will add it to Trust Store behind the scene. (If Laragon doesn't havee privileges to do that, you need to add yourself in Menu > Apache > SSL > Add to Trust Store)


  • | 812 points

    @leokhoa: "However, if you only want localhost, the solution is easy: Just disable Laragon Auto Create SSL feature."

    Where is that feature located?. I mean: "Laragon Auto Create SSL".
    How do I switch it on/off?

    Thanks!


  • administrators
    | 97623 points

    @toshiba : You uncheck Menu > Laragon > Apache > SSL > Enabled


  • | 812 points

    thanks @leokhoa!


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.