Noob question installing a 32 bit version of Laragon...


  • | 258 points

    Hi,

    I downloaded the laragon-wamp exe file, installed it and started it...
    And Apache failed; stating This version of C:\laragon\bin\apache\httpd-2.4.27-win64.. httpd.exe is not compatible with the windows version used.

    Well, I know; I'm working on an old windows 7. 32 bits machine.

    I downloaded the apache 2.4.35 win32 files, chucked them in a new folder in bin/apache called httpd-2.4.35-win32... VC14 and switched laragon to this apache folder. Alas, I get another errormessage, stating the php version is incorrect.
    So, installed the 1.7.23-Win32-VC14-X86 version, and now I get yet another error; icudt57.dll is not suitable for windows or it contains an error. So downloaded that and chucked tin the correct folder...

    And now Laragon stopped responding.
    I tried starting MSql, but that resulted in an Laragon 216 error, crashing it.

    My question now is... Is there an 'easy' way to make Laragon install all the proper 32 bit versions?


  • administrators
    | 93974 points

    @OBSThor : Actually, you can add 32-bit versions of Apache, PHP, MySQL, git, Node.js to Laragon yourself but it seems complicated for newcomers. I will make a 32-bit version of Laragon in a couple of days - will keep you posted.


  • administrators
    | 93974 points

    @OBSThor : You can download Laragon 3.5 32-bit version here:
    https://laragon.org/download.html


  • administrators
    | 93974 points

    Remember to rename your current Laragon to C:\laragon.bak before proceeding.


  • | 258 points

    Leokhoa, works like a charm! Only thing missing is Ngrok, but maybe I don't need it ;)
    PLs. mark as solved.


  • administrators
    | 93974 points

    @OBSThor : Ngrok is moved to Menu > www > Share


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.