Fatal Error when I change PHP version to 7.2.*


  • | 517 points

    Hi,

    Everything else works great but when I try to change my active PHP version 7.1.20 to versions 7.2.* I get "Fatal error: Uncaught Error: Call to undefined function mysql_connect() in..." type of error when I visit local sites and a white screen. Then I revert back to 7.1.* versions and everything loads fine.

    Is there a simple way to upgrade PHP without crashing WordPress installations?


  • | 517 points

    [Resolved] "The VC15 builds require to have the Visual C++ Redistributable for Visual Studio 2017 x64 or x86 installed" - source: https://windows.php.net/download/

    I have installed the redistributables and now VC15 versions of PHP and Apache work without issues.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.