Installed Update (v4.0) with Installer - cannot start Laragon-Port 80 used by Portable version

  • | 2288 points

    When I started using Laragon this past month, I installed the portable version instead of the full install.

    Now the update (v4.0) arrived and I used the installer exe file to update Laragon.

    When I tried to use Laragon via the icon on the desktop, which was installed by the regular installer, I got the error,

    "Failed: Apache httpd-2.4.35-win64-VC15"

    with a pop-up that said,

    "Service Apache can not start. Reason: Port 80 is in use!"

    I used the netstat to find what is using Port 80 and found that it was the Portable version, yet the I did not start the portable version specifically, I used the icon installed by the installer.

    It appears the installer installed the update over the portable install, yet I seem to be getting 2 instances active, the portable and the regular install.

    I would rather not change port numbers, because I only want 1 laragon installed, not both.

    What do I do to clean this up, to remove the portable version completely, so when I start Laragon only the one I installed as the update is the one working and uses Port 80?


  • administrators
    | 131219 points

    @mark2090 : Did you install to 2 separated folders?

    Just stop Laragon in the Portable and start the new Laragon.

  • | 2288 points

    That would be easy if I did install 2 folder, but no, I did the update install to the same folder I installed the portable.

    More info,

    The program taking up port 80 is,

    If I stop that exe file I have to restart Laragon, so Laragon is using that exe file but cannot load Apache because the exe file is taking up port 80,

    Curious, this is what it looks like in the Laragon client window,

    Failed Apache httpd-2.4.35-win64-VC15 80
    MySQL mysql-8.0.13-winx64 started 3306
    Nginx nginx-1.14.0 started 80

    Would giving Nginx another port fix the issue?

  • | 2288 points

    Found the answer.

    I went to Menu > Preferences > Services & Ports.

    I changed one of the entries, Nginx or Apache to a different port number, in this case Apache was changed to port 81.

    Now it works, no port clashes (like clash of the titans).

    I also updated again today using version 4.0.1 and that also set both Nginx and Apache to the same port.

    As much as I said I did not want to change ports, I realized I had to since Apache and Nginx were fighting for the same port number.

    Here is a question, "Why did the install set both Nginx and Apache to the same port number when they would obviously clash?" (- shouldn't each of them, by default, get assigned different port numbers?)

  • administrators
    | 131219 points

    Hi @mark2090 : It is definitely a bug when installing. I'll check it fix it soon. Thanks.

  • | 2288 points

    After all these years, I have noticed that I was born to find techie "bugs". It just happens...its a burden...

    Glad to help.

  • | 485 points

    @mark2090 Sorry to rehash this older post, but are there any implications of setting the port to 81?

  • | 2288 points

    No, so long as nothing else is using the same port. If port 81 does not work, neither port 80, and you cannot find anything else using port 80 (or 81), then change to another port.

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.