Problem with "Quick app"

  • | 646 points


    First, thanks for this great tool.
    I am testing the "Quick app" part but there is a problem :

    • Quick app -> Wordpress : works fine
    • Quick app -> Prestashop : download don't start (even after waiting minutes)

    Do you have any idea why Wordpress download is working but Prestashop is not ?

    Thank you !

    alt text

  • administrators
    | 131225 points

  • | 646 points

    @leokhoa : Thank you for the quick answer.
    I think I found the problem when trying to download the same files with the curl command from Windows.

    • Wordpress works
    • Prestashop and another project don't

    Both not working downloads are from Github. To solve the problem I have to add "-L" option (follow redirects).
    Is this the same problem with Laragon ? Don't know what command is used to download files but maybe this could be the solution.

    Thanks for your feedback !

    Edit / more details :

    In most cases, zip file has been downloaded in the /tmp/downloads folder and I can open/extract it
    (Prestashop case : I can't open or even delete the zip file)
    In all cases : the project folder is not created in /www folder (and no download progress like my screenshot)

    The problem is the same with github downloads in "right clic > tools > quick add".

    Hope it can help !

  • administrators
    | 131225 points

    @kemar2012 : I've checked and Prestashop worked well (it means I already added the -L option). Did you try using Proxy?

  • | 646 points

    @leokhoa : That's strange. Yes I've tried with some proxy IP's but that didn't work.
    I give up, thank you for your time !

    I'll use "project=composer...." or local files, instead of urls.
    Btw, I tried "project=git clone...." without success. Will you implement this feature ?

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.