Connection Not Secure using SSL

  • | 150 points

    Re: Your connection is not private

    I'm experiencing the same problem as the related topic above. Only that I'm using a {project}.test instead of {project}.dev and I'm still getting the connection not secure error.

    I have researched and tried every possible thing I could find but it doesn't seem to work.


    Laragon screen.

  • | 356 points

    Hi @edbella

    This will happen on any web-server when using a self-signed certificate, which is quite usual for a development environment. First when the site is published online one would get a trusted certificate for the public domain or IP.

    This warning can be ignored as long as you develop the website on your local machine. The warning looks different in each web-browser, where this looks to be from Firefox. As I remember, in Firefox you can click the "Advanced" button and choose to add an "exception", thus hiding the error from the local domain.

  • | 771 points

    You can import the self signed certificate to the local store. Then it will be trusted. Ping me when needed help.

  • | 150 points

    @fysioski How do i carry out the import?

  • | 771 points

    Sure @edbella. Just goto the Laragon folder and then to /etc/ssl. In there you will find the laragon.crt. Double click it and choose install certificate. --> Choose local computer --> then next button, a popup will appear and click OK --> Choose All certificates in library and click browse --> a popup will appear. Choose the basic trusted one and click ok --> Click next and finish. You are done now. ping me when needed screenshots.

  • | 290 points

    @fysioski Hey , i tried it this way but still it doesnt work, any idea what can be wrong?

    Found it! Issue was that firefox needs to have enabled certs like this:

    The simplest is to make Firefox use the Windows trusted Root CAs by going to about:config, and setting security.enterprise_roots.enabled to true.

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.