Laragon Apache - htaccess is being ignored


  • | 84 points

    I've already edited the httpd.conf. Mod_rewrite is enabled.

    LoadModule rewrite_module modules/mod_rewrite.so

    DocumentRoot "C:/Users/mda/Desktop/Work/example.com"
    <Directory "C:/Users/mda/Desktop/Work/example.com">
    Options All
    AllowOverride All
    order allow,deny
    allow from all
    </Directory>

    Have a .htaccess file in document root. No matter what i change it to, nothing happens How do i solve?


  • administrators
    | 115186 points

    @md458 : You should use Apache 2.4 settings:
    https://httpd.apache.org/docs/2.4/upgrading.html


  • | 117 points

    @leokhoa
    from what I gather in link is one should use AllowOverride All in order to allow .htaccess being processed, which I have in my .conf file. But it still gets ignored....


  • | 101 points

    I encountered similar issue when i initially moved to Laragon. The fix is actually simple.

    Laragon is compiled with its httpd.conf set to reject overwrite on the document root.
    To edit this, check the file on
    {LARAGON_ROOT}/bin/apache/httpd{other-version-details}/conf/httpd.conf
    and the file somewhere around line 251 to 278 change AllowOverride to All and restart your Laragon Server.

    That fixes it


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.