Pretty links stopped working on WordPress site


  • | 216 points

    I'm using /%postname%/ for my WordPress links and now I can't access any page, all I get is 404 error.

    Even tried deleting Laragon and creating a new WordPress site, still getting 404 error.

    I'm using v4.0.12.

    Is it possible this has to do with mod_rewrite?


  • administrators
    | 120219 points

    @leandroprz : Any images?
    You must have made some actions that caused pretty liks stopped working.


  • | 216 points

    I changed nothing, that's the strange thing.

    I just used a fresh install of Laragon and a fresh install of WordPress and it's not working.


  • | 646 points

    @leandroprz is Apache mod_rewrite enabled ?

    • Right click in Laragon > Apache > httpd.conf
    • Search for mod_write
    • uncomment line #LoadModule rewrite_module modules/mod_rewrite.so ( remove # )

  • | 216 points

    This line is not commented:
    LoadModule rewrite_module modules/mod_rewrite.so

    And my .htaccess looks like this:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    So it should be working, but it is not.

    I even went back to a previous version (4.0.4) and I'm still getting a 404 error.

    Edit: I had v4.0.3 installed on another computer, made a copy of that onto the computer where this wasn't working and now I don't get 404 errors. Weird.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.