Reloading apache keeps resetting 00-default.conf for letsencrypt


  • | 307 points

    I replaced the default certificate lines with
    SSLCertificateFile C:/laragon/etc/ssl/fullchain.pem
    SSLCertificateKeyFile C:/laragon/etc/ssl/privkey.pem

    If I stop and start the server its fine but if I restart the apache it reverts back to
    SSLCertificateFile C:/laragon/etc/ssl/laragon.crt
    SSLCertificateKeyFile C:/laragon/etc/ssl/laragon.key

    Is it possible to keep it permanent with my letsencrypt cert?


  • administrators
    | 125583 points

    @saudiqbal : Please don't change the 00-default.conf, update your Virtual Host file in instead (and remember to remove the auto. prefix so Laragon will respect your changes).


  • | 307 points

    Where do I find the file with auto. prefix? I removed it from "C:\laragon\etc\ssl\auto.openssl.conf" and it still keeps coming back.


  • administrators
    | 125583 points

    @saudiqbal : Just open Menu > Apache > sites-enabled


  • | 307 points

    Not helping it keeps coming back auto.openssl.conf and 00-default.conf
    I removed auto. from openssl.conf


  • administrators
    | 125583 points

    @saudiqbal : Remove auto. from your Virtual Host file which located in Menu > Apache > sites-enabled please.

    Please don't change the 00-default.conf, update your Virtual Host file in instead (and remember to remove the auto. prefix so Laragon will respect your changes).

    Also, because you use Let's Encrypt, just ignore the file C:\laragon\etc\ssl\auto.openssl.conf


  • | 307 points

    0_1560657650846_sss1.png

    I select Delete all and reload apache and everything comes back.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.