Fresh Install won't work.

  • | 1098 points

    I downloaded a fresh copy of Laragon since my other version was way out of date but it doesn't seem to be working from the fresh download. I uninstalled the old version from add/remove programs and try to install fresh and I get the error below.

    Download > Laragon Full from here

    ![0_1562601397637_Untitled.png](Uploading 100%)

    Actually I can't attach the image either it says I do not have privileges for this action. It says an odd error "Oops! Not a right MySQL path! Please double check! [path] Missing file: [path]

    And then Service MySQL can not start!. Reason:
    The system cannot find the path specified.

  • | 1686 points

    Hi donk,

    sorry for the obvious question but... have you tried restarting the pc? for similar errors it is often the path has been written but in order for it to take effect a restart is needed.

    if not try this link



  • | 1098 points

    It's usually the obvious ones that fix issues, right? :) No problem at all. Let me try that.

    EDIT: I just restarted my laptop completely and still get the same error. :(

    Actually, somewhat different now, soI changed the MySql version to 5.7.24 and now it just freezes with in red "Initializing data... C:\laragon\data\mysql" but never completes

  • | 1098 points

    I solved it. Thanks to the thread you linked, I deduced that Laragon doesn't completely uninstall the old version when you run the uninstaller through Add/Remove programs.

    So I 'uninstalled' it and then manually went into program files and deleted the entire Laragon folder and leftover files.

    After reinstalling it fresh once more, everything is working properly now.

  • | 1686 points

    Glad to have helped mate, I've come to realise that a lot of the problems we come across in laragon has happened with other people in other apps already so a web wide search will often bear fruit (that is not to say the people here aren't awesome, just that the answer is normally out there somewhere already)



  • | 52 points

    Hola me acaba de pasar exactamente lo mismo pero usando mariadb-10.4.13-win32, el error marcaba un problema de rutas así que al folder solo le quite "-win32" quedando "mariadb-10.4.13" y funciona correctamente

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.