Postregre Windows 10 - Erro libwinpthread


  • | 44 points

    ![0_1564330991989_libwinpthread-1-dll.jpg](Uploading 100%)

    Hello, I am trying to install postgre with laragon on my windows10 but it is generating this error, can you help me?


  • | 210 points

    I've got the same problem. I've tried to install postgresql through Laragon's menu :
    Tools > Quick add > Postgresql 11

    It download well, it extract correctly in my laragon tmp folder but... I've got a strange message about creating a folder in C:\windows\system32...
    It didn't works anyway, so I manage to copy pgsql folder from tmp to laragon\postgreslq existing folder.

    And then I've got this message and laragon is not able to start postgresql
    (in laragon\postgresql\pgsql\lib there was no libwinpthread.dll)

    Could someone help about that? thanks. :-/


  • | 210 points

    [Solved] from another post on this forum, so I hope it could help:
    @catalin560 : Quick fix for PostgreSQL 11:
    You can copy the file C:\laragon\bin\git\mingw64\bin\libwinpthread-1.dll to your Postgres bin (where psql.exe is located).
    Hope it help.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.