Laragon 4.0.16 & MySQL 8.0.18 - MySQL cannot start

  • | 154 points

    I'am using Laragon 4.0.16 (190914) and MySQL 8.0.16 but when I want to start MySQL server it throws an error "Service MySQL can not start. Reason: Unknown. Please check MySQL log file".

    I'am on Windows 10.

    Attached is MySQL log file for review : 0_1574132412948_mysqld.log

  • | 430 points

    I ran into the same earlier, but it boils down that you need to initialize MySQL again. It's missing mandatory tables.

    1. Delete largon/data/mysql-8
    2. cd to laragon/bin/mysql8.0.0.x/bin folder via cmder (important for step 3)
    3. run 'mysqld --initialize --console' (remember the password)
    4. run 'start mysqld'
    5. run 'mysql -u root -p'
    6. put in the password from 3.
    7. You are now in mysql shell and can remove the password again: "ALTER USER 'root'@'localhost' IDENTIFIED BY '';"
    8. run 'exit' and ctrl + c the spawned tab from step 4.

    This should work. Solution is also available from this forum, that is where I got it from in the first place.

  • | 528 points

    @Mr-Pingu, just correct step 4 to command "start mysqld" and then run 'exit' and close the other console with ctrl+c.

  • | 430 points

    @imeiul Thanks for your sharpness :)

  • | 154 points

    @Mr-Pingu , thank you so much.
    I'am sorry for asking this question, but i didn't find the same problem and solution has already existed in this forum.

    Just want to update step 2; cd to laragon/bin/mysql8.0.0.x/bin folder via cmder (important for step 3)

    Thank you again. :grinning: :thumbsup:

  • | 430 points


    It was somewhere tucked away. But I know I got it from somewhere here, it's just that I couldn't refind it either so wrote this new instructions based on my notes ;)
    Thanks, updated step 2 as well for if someone happens to run into the same problem later again.

  • | 967 points

  • | 54 points

    @Mr-Pingu Thanks man you are a genius, had spent 2 days scratching my head and your solution worked perfectly. Now my laragon is up and running with no issues whatsoever, myphpadmin logged on without any issues. Thanx

  • | 139 points

    @Mr-Pingu thank you

  • | 1017 points

    @Mr-Pingu thank you so much, it's helped me re-start the MySQL but I'm losing all the available database because it can't load the exists database after install those mandatory tables :(.

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.