Pings but no connection

  • | 3458 points

    Phew... I have tried everything I can think of to connect from other LAN computers to Laragon.

    When I install Laragon, and then WordPress, I can access WP with no issues so long as I am on the computer where Laragon is located. However, all attempts to connect from other computers fails with "cannot connect" messages.

    I have removed and reinstalled all a few times to no avail. I have dropped all firewalls and still no change. The odd thing is that I can ping to the IP addy with no issues, but cannot even get the Laragon screen at that IP address.

    I am not using Nginx and prefer to just access without it since this all on localhost. And, I have had Laragon in the past working fine, but something is obviously at work blocking things. Any suggestions and ideas solicited and appreciated.


    This morning, from remote on LAN to computer with Laragon:

    Ping Laragon address Passes

    Accessed server computer over LAN by computer name in Windows Explorer Passes - Displayed&Accessed all drives properly.

    Access Laragon over LAN in browser as http://computername Passes and displays Laragon screen

    Access Laragon over LAN in browser as Fails: ... can't establish a connection to the server at

    Access Laragon over LAN in browser as http://computername/eco1 Fails - Changes address to:
    Then returns ... can't establish a connection to the server at

    In httpd.conf changed <Directory /> "Allow Override to all" No Change fails to connect

    Attempted to upload phpinfo() but do not not have enough privileges.

  • administrators
    | 135124 points

    @adminnga : I think it is related to Firewall.

  • | 3458 points

    Hi Leo,

    Thanks for picking up this thread.

    I have two firewalls on each computer. One is Webroot Secure and the other is Windows defender. I also thought that either firewall could be blocking things. It was actually the first thing I thought of and I tried to see if there were issues in either with allowing things through by looking at the settings. That got no results.

    So, just to be sure, on multiple occasions, after disconnecting the outside internet, I entirely shutdown Webroot and turned off Windows Defender, meaning there were no firewalls at all. After which I rebooted both computers and nothing changed.

    What seems strange to me, and you would no doubt know better, is that I can connect to Laragon, although not WP, by typing the computer name into the remote computer; after which, even with firewalls in place, I get the Laragon screen on the remote computers. At the same time, if I type the address, which is the address shown in Laragon, I get the cannot connect screen in the browser.

  • administrators
    | 135124 points

    Hi @adminnga.

    Can you access your site using ngrok? Menu > www > Share

  • | 3458 points


    Since this is only used on localhost, and will never be anything other than that, in the past I never did use ngrok. However, when this problem started I tried to use it to see if I could make any kind of connection, but after checking the ngrok boxes Laragon threw, and still throws, a "Service Ngnix cannot start" error as follows:

    nginx: [emer]
    BIO_new_file("C:/Laragon.crt") failed
    (SSL:error:02001002:system library:fopen:No such file or
    error:2006D080:Bio routines:Bio_new_file:no such file)

    At this point I just went back to normal non-nginx to see if I could find a way to access.

    Also, I thought that perhaps the version might have had an issue, or the install file may have had corruption, so I deleted v4.0.16.0 and installed v4.0.12_2019-128-231253. That did not help. I am still on v4.0.12 since versions are not the issue. I'll change back to the current version when the issue is solved.


  • | 3458 points

    Still stuck on this one. After yet another clean install, I did get it working for a short time although I am not sure why it worked. Too many changes in all the settings to be sure, but it was working - then a shutdown, went to bed, and in the morning back to the same after booting the computer.

    Can you tell me if Laragon is using VirtualBox. After reinstall of Windows, for use with another program, I installed that program prior to installing Laragon a short time later.

    Any ideas?

  • administrators
    | 135124 points

    @adminnga : Laragon does't use VirtualBox.
    From the error directory:fopen('C:Laragon/etc/ssl/laragon.crt','r')

    It happened because the right path should be: C/:Laragon/etc/ssl/laragon.crt

  • | 3458 points

    Thanks Leo.

    This one is for the "who will really ever know what went on" books, but I did get it put right.

    The problem, I think, was that VirtualBox was somehow grabbing (at times) the primary network adapter. When I thought this might be the problem, I attempted to change the IP address it used, but it made no difference, it still was somehow fooling about in the background and messing up any attempt to get things working (most times).

    This morning, I removed it and Laragon completely. I then deleted all directories and files from the hard drives for both programs and deleted all references to them in \users. After this, I removed applicable registry entries for both and rebooted. Next was to run Windows Network Reset and again reboot. After that, all was right.

    What was really odd, Leo, was that if I changed the IP address in VirtualBox the IP address that Laragon would bind to was the same as that which I entered into VirtualBox. As well, if I tried to get Laragon to use the primary network adapter it just would not, save for sometimes when it would, and this drove me crazy because it somehow kept giving the impression that VirtualBox was in the loop. It was, but wasn't supposed to be.

    When I get them I always get the oddest problems.

    All is well again and Laragon is back to rock and rolling! Thanks again.

  • administrators
    | 135124 points

    @adminnga : I'm glad the you found the issue.
    Laragon could detect and ignore IP from VirtualBox. However, the process take time so I removed the feature.

  • | 57 points

    hello i have the same problem with Hyper-v
    it use the virtual switch
    i use the portable version.
    if someone have a solution.


Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.