localhost URL redirects to my virtual host


  • | 362 points

    Hi there,

    Need a little help to troubleshoot this weird issue.

    I have several Laragon vhost for my projects enabled (set manually) under the etc/apache2/sites-enabled folder. They are ok.

    The problem is my project folders that are not using vhost are no longer accessible using the standard http://localhost/xxxxx URL. Instead it renders the webpage of the first configured vhost in the list but the URL remains as http://localhost/xxxxx.

    If I remove all the vhost .conf files, the localhost URL works again.

    Can anyone help please?

    Thanks.

    Example of .conf file is like this

    define ROOT "D:/laragon/www/portal.members.zzz/wordpress"
    define SITE "portal.members.zzz"
    
    <VirtualHost *:80> 
        DocumentRoot "${ROOT}"
        ServerName ${SITE}
        ServerAlias *.${SITE}
        <Directory "${ROOT}">
            AllowOverride All
            Require all granted
        </Directory>
    </VirtualHost>
    

  • | 362 points

    Well what do you know, I just solved it by clicking on Menu > Apache > Reload.

    It created a 00-default.conf file in the apache sites/enabled folder which I probably have deleted inadvertently.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.