Install Rails


  • | 375 points

    Hi! Noob here.

    I just read up on Laragon and decided to give it a try. I want to have a Rails dev environment, but I can't get past the first step.

    I setup Laragon, added Ruby, then tried gem install rails. It failed with an error that the ruby isn't up to minimum.


    E:\laragon\www
    λ gem install rails
    Fetching: concurrent-ruby-1.1.5.gem (100%)
    Successfully installed concurrent-ruby-1.1.5
    Fetching: i18n-1.8.2.gem (100%)

    HEADS UP! i18n 1.1 changed fallbacks to exclude default locale.
    But that may break your application.

    If you are upgrading your Rails application from an older version of Rails:

    Please check your Rails app for 'config.i18n.fallbacks = true'.
    If you're using I18n (>= 1.1.0) and Rails (< 5.2.2), this should be
    'config.i18n.fallbacks = [I18n.default_locale]'.
    If not, fallbacks will be broken in your app by I18n 1.1.x.

    If you are starting a NEW Rails application, you can ignore this notice.

    For more info see:
    https://github.com/svenfuchs/i18n/releases/tag/v1.1.0

    Successfully installed i18n-1.8.2
    Fetching: thread_safe-0.3.6.gem (100%)
    Successfully installed thread_safe-0.3.6
    Fetching: tzinfo-1.2.6.gem (100%)
    Successfully installed tzinfo-1.2.6
    Fetching: zeitwerk-2.2.2.gem (100%)
    ERROR: Error installing rails:
    zeitwerk requires Ruby version >= 2.4.4.


    Any ideas? What did I do wrong since Laragon installs Ruby 2.3.3.

    Thanks in advance for any help.


  • administrators
    | 125850 points

    zeitwerk requires Ruby version >= 2.4.4

    I will consider to upgrade Ruby soon


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.