MySQL 8 - some issue and kinda stuck

  • | 201 points

    after a few of try and error to make mysql service started including set mysql data to mysql instead of mysql-8, now mysql service run ok and i can access/login mysql in command prompt and login thru heidisql & phpmyadmin.

    everything seems ok..but wait

    when i try to create db from laragon menu, it throw error "connect to server at localhost failed. access denied for user root@localhost (use password: NO)" eventho I already set the password for root user.

    this happen too when i try to create quick app like laravel n wordpress.

    so, i try to create the db using command prompt. so i run mysql -u root -p, then key in the password, then welcomed by mysql welcome message, then i hit create database blablabla, bam! same error as above.

    man, i am so confuse right now and dunno what to do

    any idea?

  • | 793 points

    I've had issues when trying to use v8 mysql.
    I reverted to a previous version.

    That is correct I believe that you cannot login as root possible with v8, and you can create a dbuser or dbadmin, and set password, but, then also go into privileges and allow user to all privileges.

    I thought it would automatically set that up for me, but it didn't.

    Try that and then see if you have the privileges levels you need for creating db's/tables, etc...

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.