[SOLVED] Installed Laragon -> can no longer access my website online?


  • | 343 points

    Hi,

    I just installed Laragon instead of wamp. And now I have a big problem. I can no longer open one of my online websites. It keeps trying to show the local site.

    I added a folder (in /www) with the same name as the domain of my website: "mydomain.com"

    Now, when I type "mydomain.com" into the address line in the browser (firefox, chrome and edge) it goes to the local file instead. I tried deleting the local folder, but now it just shows the index file of the root (same as when typing localhost). I can also not go to a subfolder on the online site (e.g. "mydomain.com/wp-admin")

    The website works fine from other computers on the same network, so it is online.

    Also it changes "http://" to "https://", the online site does not use https...

    When this happened "auto virtual hosts" was off. I have tried enabling and disabling that, no difference.

    How to I make it so that i can open my online website in my browser again?

    Any help is much appreciated, thank you.


  • | 343 points

    More info: when i ping mydomain.com the ip-address is [::1] not the actual online ip address. other domains ping correctly.


  • | 343 points

    Okay, I found the problem and the solution.

    I removed the lines with this domain from the file
    C:\windows\system32\drivers\etc\hosts

    • edit with notepad (run as admin)

    Answer was here: https://stackoverflow.com/questions/38231590/how-to-delete-a-wamp-virtual-site

    Thanks


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.