How turn of sql_mode=ONLY_FULL_GROUP_BY


  • | 221 points

    I use Laragon as my localhost server. Am using a script that requires sql_mode=ONLY_FULL_GROUP_BY to be turned off in my.ini. A page doesn't load to the next page when a submit command is executed.

    If i Execute this command in phpmyadmin -> SQL -> SET GLOBAL sql_mode=(SELECT REPLACE(@@sql_mode,'ONLY_FULL_GROUP_BY','')); The script start functioning properly. But after system or Laragon restart the problem start again, so it seems laragon automatically turns on sql_mode=only_full_group_by.

    I have checked my.ini file in

    I was ask by my script developer to look for sql_mode in my.ini and remove ONLY_FULL_GROUP_BY. In laragon directory i couldn´t find sql_mode=ONLY_FULL_GROUP_BY in C:\laragon\bin\mysql\mysql-5.7.24-winx64\my.ini

    Is there any way to turn off sql_mode=only_full_group_by without doing it from PhpMyadmin?


  • | 324 points

    Open your phpMyAdmin and go to variables tab.
    Search for keyword "sql_mode".
    You will see like this
    alt text
    Copy that input box.
    Open your my.ini
    alt text
    Add this "sql_mode=" + ur copied text from phpmyadmin but delete the ONLY_FULL_GROUP_BY.
    alt text
    Save it and restart the mysql.
    Problem solved!


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.