Where is the PHP Config module?


  • | 219 points

    I am having trouble using the Xdebug extension inside PHPStorm. I have read that the solution is to disable the symlink in the PHP config module to the OpCache.

    Secondly, which php.ini is the active one? Have have a development, a production and a non descript one.

    Thanks !


  • | 2024 points

    Xdebug
    See the PhpStorm guide and video here:

    PHP.ini
    Open Laragon, Menu > PHP > php.ini

    The PHP.ini will open the for the selected version of PHP.

    0_1600810930455_upload-9645cf95-c66e-4ae4-a85a-80b44ae323f3


  • | 219 points

    @Pen-y-Fan Thank you for the rapid reply. I think the PHP config module is different from the PHP.ini file. Im looking at a successful reply on StackOverflow to my problem and they say to solve it I must:

    Disable the OpCache module by removing the symlink in the PHP modules config and you're able to see the local vars as expected.

    The full response is here: (https://stackoverflow.com/questions/50611743/why-are-variables-not-showing-in-the-debug-window-in-phpstorm)

    Essentially my problem is that Xdebug with Laragon is not delivering all the values in the Xdebug variables tab.

    Thanks !


  • | 2024 points

    Sorry, I'm confused, I need more information on your setup, the SO link is to do with a docker config. Not Laragon.

    Your CLI Interpreters in PhpStorm should be setup something like this for Debugging with Laragon:

    0_1600813883248_upload-dd75d940-e443-4923-b98e-18788a2539bb

    0_1600814072988_upload-6f4de7ad-7020-413d-b189-ae1ba8c6af0b

    0_1600814033221_upload-c655f2ea-a5a8-4f72-84ae-0c687484ab3b


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.