Install issue - vcredist/Visual C++ Redistributable for Visual Studio 2015


  • | 4006 points

    After installing the Visual C++ Redistributable for Visual Studio 2015 recommended here: https://forum.laragon.org/topic/203/how-we-move-our-php-scripts-with-laragon-files-to-another-computers

    I still get the following error:

    The program can't start because api-ms-win-crt-runtime-|l1-1-0.dll is missing from your computer. Try reinstalling the program to fix this problem.

    My PC is 64 bit and in the image you can see the vcredist I have installed for both 64 bit and 32 bit...

    0_1473409896586_vcredist.PNG

    Please note that I uninstalled Laragon and removed all files then installed the Visual C++ Redistributable for Visual Studio 2015 then finally reinstalled Laragon but still have the same error.

    Any assistance would be highly appreciated! Thank you.


  • administrators
    | 43892 points

    What is your PHP Version?
    The answer was for PHP 7 which needs Visual Studio 2015. (VC14)

    You might need VC11 (for PHP 5.6, 5.5)
    Ref: http://windows.php.net/download


  • | 4006 points

    @leokhoa Thanks for your reply.

    I think it is version 7. I was trying to install the latest laragon which I assumed had 7 as a default.

    Unless I've misunderstood what's going on, is the issue actually with apache not php? See images below which mention apache, (httpd.exe):

    0_1473417150529_1.PNG

    0_1473417171083_2.PNG

    0_1473417177537_3.PNG

    I've also tried running httpd from the command line but I get the same error in the first image.

    I'm already up and running with Laragon on my work machine which runs fine and ran into issues here with my personal laptop.

    I'm going to try running all my windows updates also, some are suggesting this is an issue on stackoverflow.


  • administrators
    | 43892 points

    I'm just afraid of your VC14 installation (missing or wrong in something).
    Please try installing using Laragon installer (on different folder like C:\test), the installer can detect and install VC14 for you.

    PS: VC14 32-bit is used for PHP 7.0.10-Win32-VC14-x86 and Apache 2.4.23-win32-VC14


  • | 4006 points

    @leokhoa Thanks I'll try installing into another folder.

    My windows updates are not functioning correctly so I think this may be the issue!

    Many thanks for your replies. Great to see such amazing support for your awesome software!


  • administrators
    | 43892 points

    @haakym: No problem :)


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.