OpenSSL doesn't work

  • | 369 points

    D:\laragon\www\wiki {git} 31.12.2015 19:53:10,03
    {lamb} openssl
    WARNING: can't open config file: c:/openssl-1.0.2d-win32/ssl/openssl.cnf
    OpenSSL> req -x509 -nodes -days 365 -newkey rsa:2048 -keyout -out
    Unable to load config info from c:/openssl-1.0.2d-win32/ssl/openssl.cnf
    error in req

  • administrators
    | 76508 points

    You can add environment variable:

     set OPENSSL_CONF=C:\laragon\bin\apache\apache-2.4.17\conf\openssl.cnf

  • | 369 points

    Thank you, leokhoa! Now openssl works.
    But now I can't make http and https work on ports, other than 80 and 443 correspondingly.
    I checked firewall settings: all ports for httpd in laragon are allowed.
    Can you give a hint where to search for this problem?
    By the way, if I change ports in the Laragon Settings, it overrides port 443 in httpd-vhosts for 80.

  • administrators
    | 76508 points


    1. On httpd.conf, please make sure this line is uncoment:
    Include conf/extra/httpd-ssl.conf
    1. On conf/extra/httpd-ssl.conf, you can append this (you may need to what I make bold properly):

    <VirtualHost *:8443>

    DocumentRoot "C:/laragon/www/wiki/"

    SSLEngine on

    SSLCertificateFile "${SRVROOT}/conf/ssl/"
    SSLCertificateKeyFile "${SRVROOT}/conf/ssl/"


  • administrators
    | 76508 points

    Browser to:
    It should work.

    Please be aware that on conf/extra/httpd-ssl.conf, you must see that:

    Listen 8443

    If you change to other value manually (ex: 443), you must change the VirtualHost correspondly.

    Listen 443
    <VirtualHost *:443>

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.