MySQL won't start on other device


  • | 613 points

    Hello there,

    Let me start with thanking you for this fantastic tool!

    I just moved from WAMP to Laragon last week. Main reason was because of the portability. I want to sync my Laragon folder between my desktop and my laptop through a cloud service (similar to Dropbox).

    I have installed the full version of Laragon on my desktop. This works like a charm. I put the entire Laragon folder on my cloud drive.
    Then on my laptop, I synced the folder and started Laragon. Apache works, but MySQL is throwing an error. See logs below:

    2021-02-05T09:40:27.231569Z 0 [Warning] Insecure configuration for --secure-file-priv: Current value does not restrict location of generated files. Consider setting it to a valid, non-empty path.
    2021-02-05T09:40:27.232009Z 0 [Note] C:\Users\***\stack\Dev\laragon\bin\mysql\mysql-5.7.32-winx64\bin\mysqld (mysqld 5.7.32) starting as process 2632 ...
    2021-02-05T09:40:27.252395Z 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
    2021-02-05T09:40:27.253386Z 0 [Note] InnoDB: Uses event mutexes
    2021-02-05T09:40:27.254014Z 0 [Note] InnoDB: _mm_lfence() and _mm_sfence() are used for memory barrier
    2021-02-05T09:40:27.254954Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
    2021-02-05T09:40:27.256102Z 0 [Note] InnoDB: Number of pools: 1
    2021-02-05T09:40:27.256959Z 0 [Note] InnoDB: Not using CPU crc32 instructions
    2021-02-05T09:40:27.261456Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
    2021-02-05T09:40:27.275591Z 0 [Note] InnoDB: Completed initialization of buffer pool
    2021-02-05T09:40:27.330404Z 0 [ERROR] InnoDB: Only one log file found.
    2021-02-05T09:40:27.331196Z 0 [ERROR] InnoDB: Plugin initialization aborted with error not found
    2021-02-05T09:40:27.554689Z 0 [ERROR] Plugin 'InnoDB' init function returned error.
    2021-02-05T09:40:27.556396Z 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
    2021-02-05T09:40:27.558097Z 0 [ERROR] Failed to initialize builtin plugins.
    2021-02-05T09:40:27.559483Z 0 [ERROR] Aborting
    
    2021-02-05T09:40:27.560527Z 0 [Note] Binlog end
    2021-02-05T09:40:27.561628Z 0 [Note] Shutting down plugin 'CSV'
    2021-02-05T09:40:27.570576Z 0 [Note] C:\Users\***\stack\Dev\laragon\bin\mysql\mysql-5.7.32-winx64\bin\mysqld: Shutdown complete
    

    What is going wrong here? I tried renaming the data/ folder. It worked then, but that won't give me my databases ;)

    I'm assuming some directory/configuration mismatch?

    Thanks in advance,
    matsn0w


  • | 5029 points

    @matsn0w the same error was reported here: https://forum.laragon.org/topic/1884/new-install-of-laragon-mysql-fails-after-a-few-seconds-on-startup/4

    Seams an odd fix to add two config items to the my.ini, start MySQL, reboot and revert them, but maybe worth a try.


  • administrators
    | 127184 points

    @matsn0w : Database transactions are complicated to achieve ACID. Therefore you need to stop MySQL before syncing.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.