Mongo 4.4 CE fails to start


  • | 2043 points

    Unable to start mongo CE 4.4

    I used Mongo 3.6 Community Edition under Laragon without problems.

    I tried to switch to Mongo 4.4 but it cannot starts

    This is the logoutut

    
    "c":"CONTROL",  "id":20698,   "ctx":"main","msg":"***** SERVER RESTARTED *****"}
    "c":"CONTROL",  "id":23285,   "ctx":"main","msg":"Automatically disabling TLS 1.0, to force-enable TLS 1.0 specify --sslDisabledProtocols 'none'"}
    "c":"ASIO",     "id":22601,   "ctx":"main","msg":"No TransportLayer configured during NetworkInterface startup"}
    "c":"NETWORK",  "id":4648602, "ctx":"main","msg":"Implicit TCP FastOpen in use."}
    "c":"STORAGE",  "id":4615611, "ctx":"initandlisten","msg":"MongoDB starting","attr":{"pid":6968,"port":27017,"dbPath":"C:/laragon/data/mongodb","architecture":"64-bit","host":"MIRKO-PC"}}
    "c":"CONTROL",  "id":23398,   "ctx":"initandlisten","msg":"Target operating system minimum version","attr":{"targetMinOS":"Windows 7/Windows Server 2008 R2"}}
    "c":"CONTROL",  "id":23403,   "ctx":"initandlisten","msg":"Build Info","attr":{"buildInfo":{"version":"4.4.4","gitVersion":"8db30a63db1a9d84bdcad0c83369623f708e0397","modules":[],"allocator":"tcmalloc","environment":{"distmod":"windows","distarch":"x86_64","target_arch":"x86_64"}}}}
    "c":"CONTROL",  "id":51765,   "ctx":"initandlisten","msg":"Operating System","attr":{"os":{"name":"Microsoft Windows 10","version":"10.0 (build 19042)"}}}
    "c":"CONTROL",  "id":21951,   "ctx":"initandlisten","msg":"Options set by command line","attr":{"options":{"config":"C:\\laragon\\bin\\mongodb\\mongodb-win32-x86_64-windows-4.4.4\\mongod.conf","net":{"bindIp":"0.0.0.0","port":27017},"processManagement":{"pidFilePath":"mongod.pid"},"storage":{"dbPath":"C:\\laragon\\data\\mongodb","journal":{"enabled":true}},"systemLog":{"destination":"file","logAppend":true,"path":"C:\\laragon\\bin\\mongodb\\mongodb-win32-x86_64-windows-4.4.4\\mongod.log"}}}}
    "c":"STORAGE",  "id":22270,   "ctx":"initandlisten","msg":"Storage engine to use detected by data files","attr":{"dbpath":"C:/laragon/data/mongodb","storageEngine":"wiredTiger"}}
    "c":"STORAGE",  "id":22315,   "ctx":"initandlisten","msg":"Opening WiredTiger","attr":{"config":"create,cache_size=15807M,session_max=33000,eviction=(threads_min=4,threads_max=4),config_base=false,statistics=(fast),log=(enabled=true,archive=true,path=journal,compressor=snappy),file_manager=(close_idle_time=100000,close_scan_interval=10,close_handle_minimum=250),statistics_log=(wait=0),verbose=[recovery_progress,checkpoint_progress,compact_progress],"}}
    "c":"STORAGE",  "id":22347,   "ctx":"initandlisten","msg":"Failed to start up WiredTiger under any compatibility version. This may be due to an unsupported upgrade or downgrade."}
    "c":"STORAGE",  "id":28595,   "ctx":"initandlisten","msg":"Terminating.","attr":{"reason":"129: Operation not supported"}}
    "c":"-",        "id":23091,   "ctx":"initandlisten","msg":"Fatal assertion","attr":{"msgid":28595,"file":"src\\mongo\\db\\storage\\wiredtiger\\wiredtiger_kv_engine.cpp","line":1123}}
    "c":"-",        "id":23092,   "ctx":"initandlisten","msg":"\n\n***aborting after fassert() failure\n\n"}
    
    "c":"CONTROL",  "id":20698,   "ctx":"main","msg":"***** SERVER RESTARTED *****"}
    "c":"CONTROL",  "id":23285,   "ctx":"main","msg":"Automatically disabling TLS 1.0, to force-enable TLS 1.0 specify --sslDisabledProtocols 'none'"}
    "c":"ASIO",     "id":22601,   "ctx":"main","msg":"No TransportLayer configured during NetworkInterface startup"}
    "c":"NETWORK",  "id":4648602, "ctx":"main","msg":"Implicit TCP FastOpen in use."}
    "c":"CONTROL",  "id":23330,   "ctx":"main","msg":"ERROR: Cannot write pid file to {path_string}: {errAndStr_second}","attr":{"path_string":"mongod.pid","errAndStr_second":"Accesso negato."}}
    
    
    

    If you could help me to understand the problem, I will appreciate it


  • | 2043 points

    In the configuration, I pointed the .pid file to inside mongo bin specific version folder.
    It worked


  • | 476 points

    I'm trying to install MongoDB server 4.4.0 and try to apply your solution without any change.

    I comment all the processManagement configuration, but i've the server starting and ending in the same time. According the log file, i've a problem of database version :
    "Wrong mongod version","attr":{"error":"UPGRADE PROBLEM: Found an invalid featureCompatibilityVersion document (ERROR: BadValue: Invalid value for version, found 4.0, expected '4.4' or '4.2'. Contents of featureCompatibilityVersion document in admin.system.version: { _id: "featureCompatibilityVersion", version: "4.0" }. See https://docs.mongodb.com/master/release-notes/4.4-compatibility/#feature-compatibility.). If the current featureCompatibilityVersion is below 4.2, see the documentation on upgrading at https://docs.mongodb.com/master/release-notes/4.4/#upgrade-procedures."}}
    I read the documentation, and found the solution: if you went from version 4.0 to 4.2 no problem, it works. On the other hand, if you upgrade from version 4.2 to 4.4, before stopping the server in 4.2, you must run the command under MongoShell:
    db.adminCommand ({setFeatureCompatibilityVersion: "4.2"})
    which switches FeatureCompatibilityVersion from 4.0 to 4.2. Then you can start your server in 4.4 without any problem.
    Only downside, to go back to version 4.0, you will have to do the opposite operation with the command, having started the server in version 4.2:
    db.adminCommand ({setFeatureCompatibilityVersion: "4.0"})
    .
    I


  • | 476 points

    @celtic34fr : be careful : to change the FeatureCompatibilityVersion will make some changes to your database (structure mainly), your must extract all collection of your database(s) before change server version. Then, you have to upload all collections in new database after.
    This gives some extra work, but MongoDB's backward compatibility is only valid for one version on the next for my testing, and not two versions apart.


  • | 2043 points

    I succesfully upgrade from 3.6 to 4.0

    Next month we'll try 4.0 to 4.2

    Thanks to pointing me to the problem of feature compatibility. I didn't know it.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.